【PAT刷题甲级】1075.PAT Judge

1075 PAT Judge (25 分)

The ranklist of PAT is generated from the status list, which shows the scores of the submissions. This time you are supposed to generate the ranklist for PAT.

Input Specification

Each input file contains one test case. For each case, the first line contains 3 positive integers, N (≤10 ^4 ), the total number of users, K (≤5), the total number of problems, and M (≤10 ^5 ), the total number of submissions. It is then assumed that the user id’s are 5-digit numbers from 00001 to N, and the problem id’s are from 1 to K. The next line contains K positive integers p[i] (i=1, …, K), where p[i] corresponds to the full mark of the i-th problem. Then M lines follow, each gives the information of a submission in the following format:

user_id problem_id partial_score_obtained

where partial_score_obtained is either −1 if the submission cannot even pass the compiler, or is an integer in the range [0, p[problem_id]]. All the numbers in a line are separated by a space.

Output Specification

For each test case, you are supposed to output the ranklist in the following format:

rank user_id total_score s[1] ... s[K]

where rank is calculated according to the total_score, and all the users with the same total_score obtain the same rank; and s[i] is the partial score obtained for the i-th problem. If a user has never submitted a solution for a problem, then “-” must be printed at the corresponding position. If a user has submitted several solutions to solve one problem, then the highest score will be counted.

The ranklist must be printed in non-decreasing order of the ranks. For those who have the same rank, users must be sorted in nonincreasing order according to the number of perfectly solved problems. And if there is still a tie, then they must be printed in increasing order of their id’s. For those who has never submitted any solution that can pass the compiler, or has never submitted any solution, they must NOT be shown on the ranklist. It is guaranteed that at least one user can be shown on the ranklist.

Sample Input

7 4 20
20 25 25 30
00002 2 12
00007 4 17
00005 1 19
00007 2 25
00005 1 20
00002 2 2
00005 1 15
00001 1 18
00004 3 25
00002 2 25
00005 3 22
00006 4 -1
00001 2 18
00002 1 20
00004 1 15
00002 4 18
00001 3 4
00001 4 2
00005 2 -1
00004 2 0

Sample Output

1 00002 63 20 25 - 18
2 00005 42 20 0 22 -
2 00007 42 - 25 - 17
2 00001 42 18 18 4 2
5 00004 40 15 0 25 -

题意

输入用户数n、问题数m、提交数k. 多次提交同一题的取最高分,编译未通过或者未提交不计入总分. 未提交该题得分状态为’-’。(结构体排序)
注意:只有全部题目都未提交或者提交的都未通过编译,才不能参与排名(本人就是忽略了这一点,花了很久找bug+改代码,才通过,审题一定要仔细!)

代码

#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
struct node {
	int id,rank,sum=0;      	//id,排名,总分
	int score[6];           	//每题得分,默认为0
	int solved,never;           //获得满分的题数solved,未提交答案或者最终结果未通过编译的题数never
	bool sub[6];	        	//提交状态,默认为false(未提交)
} stu[100001];
bool exist[100001] = {false};   //标记id号是否存在
vector<node> v;                 //存储排行榜
bool cmp(node a,node b) {
	if(a.sum!=b.sum)	return a.sum > b.sum;
	else {
		if(a.solved != b.solved)	return a.solved > b.solved;
		else	return a.id < b.id;
	}
}
int main() {
	int n,k,m,a,b,c;	        //学生数n,问题数m,提交数k
	scanf("%d %d %d",&n,&k,&m);
	int p[6]= {0};
	for(int i=1; i<=k; i++) {
		scanf("%d",&p[i]);       //输入对应每题的满分
	}
	for(int i=1; i<100001; i++) {
		for(int j=1; j<=k; j++) {
			stu[i].score[j]=-2; //初始化每题得分为-2
		}
	}
	for(int i=1; i<=m; i++) {
		cin >> a >> b >> c;
		exist[a]=true;
		stu[a].id=a;
		if(stu[a].score[b]<c)	stu[a].score[b]=c;      //多次提交取最高分
		stu[a].sub[b]=true;                             //更新提交状态
	}
	for(int i=1; i<100001; i++) {
		if(exist[i]==true) {
			for(int j=1; j<=k; j++) {
				if(stu[i].score[j]==p[j])	stu[i].solved++;
				if(stu[i].score[j]>=0)	stu[i].sum += stu[i].score[j];  //除了未提交、编译未通过,其余得分
				else if(stu[i].score[j]==-1 || stu[i].sub[j]==false) {
					stu[i].never++;     				//更新未提交和未通过编译的题数
					stu[i].score[j]=0;  				//未通过得分设为0
				}
			}
			if(stu[i].never!=k)	v.push_back(stu[i]);    //只有全部题目都未提交或者提交的都未通过编译,才不能参与排名
		}
	}
	sort(v.begin(),v.end(),cmp);
	v[0].rank=1;
	for(int i=1; i<v.size(); i++) {
		v[i].rank=i+1;
		if(v[i].sum==v[i-1].sum)						//允许存在排名相同情况
			v[i].rank=v[i-1].rank;
	}
	for(int i=0; i<v.size(); i++) {
		printf("%d %05d %d",v[i].rank,v[i].id,v[i].sum);
		for(int j=1; j<=k; j++) {
			if(v[i].sub[j]==false)	printf(" -");
			else	printf(" %d",v[i].score[j]);
		}
		printf("\n");
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值