3-4 计算长方形的周长和面积(拷贝构造函数)

3-4 计算长方形的周长和面积

Time Limit: 1000MS Memory Limit: 65536KB
Problem Description
通过本题的练习可以掌握拷贝构造函数的定义和使用方法;
设计一个长方形类Rect,计算长方形的周长与面积。类中有私有数据成员Length(长)、Width(宽),由具有缺省参数值的构造函数对其初始化,函数原型为:Rect(double Length=0, double Width=0); 再为其定义拷贝构造函数,形参为对象的常引用,函数原型为:Rect(const Rect &); 编写主函数,创建Rect对象r1初始化为长、宽数据,利用r1初始化另一个Rect对象r2,分别输出对象的长和宽、周长和面积。
 
 
要求: 创建对象 Rect r1(3.0,2.0),r2(r1);
Input

输入两个实数,中间用一个空格间隔;代表长方形的长和宽

Output

共有6
分别输出r1的长和宽; r1的周长; r1的面积;r2的长和宽; r2的周长; r2的面积;注意单词与单词之间用一个空格间隔

Example Input
56 32
Example Output
the length and width of r1 is:56,32
the perimeter of r1 is:176
the area of r1 is:1792
the length and width of r2 is:56,32
the perimeter of r2 is:176
the area of r2 is:1792
 
#include<iostream>
using namespace std;
class Rect
{
 double lenth;
 double width;
public:
 Rect(double len,double wid)
 {
  if(len<0||wid<0)
  {
   lenth=0;
   width=0;
  }
  else
  {
   lenth=len;
   width=wid;
  }
 }
 Rect(const Rect &t)
 {
  lenth=t.lenth;
  width=t.width;
 }
 void put1() const
 {
  cout<<"the length and width of r1 is:"<<lenth<<","<<width<<endl;
  cout<<"the perimeter of r1 is:"<<2*(width+lenth)<<endl;
  cout<<"the area of r1 is:"<<width*lenth<<endl;
 }
 void put2()
 {
  cout<<"the length and width of r2 is:"<<lenth<<","<<width<<endl;
  cout<<"the perimeter of r2 is:"<<2*(width+lenth)<<endl;
  cout<<"the area of r2 is:"<<width*lenth<<endl;
 }
};
int main()
{
 double a,b;
 cin>>a>>b;
 Rect const r1(a,b);
 Rect r2(r1);
 r1.put1();
 r2.put2();
 return 0;
}
  • 3
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值