HDU 5056 双指针(也叫窗口滑动(也叫尺取法))

Description

You are given a string S consisting of lowercase letters, and your task is counting the number of substring that the number of each lowercase letter in the substring is no more than K.
 

Input

In the first line there is an integer T , indicates the number of test cases.
For each case, the first line contains a string which only consist of lowercase letters. The second line contains an integer K.

[Technical Specification]
1<=T<= 100
1 <= the length of S <= 100000
1 <= K <= 100000
 

Output

For each case, output a line contains the answer.
 

Sample Input

     
     
3 abc 1 abcabc 1 abcabc 2
 

Sample Output

     
     
6 15 21
 
此题允许不同位置上的相同字母算作不同种类


双指针(也叫窗口滑动(也叫尺取法)):
定义两个指针,始终保持指针内的子串符合题目要求,向右移动右指针,若不符合要求,则将左指针向右移动直到指针内的子串符合题目要求为止。这样就求出了每个点向左延伸最远符合要求的点,于是这个区间内的任意一个子串都是符合题目要求的,不断累加即可。
复杂度:On.



#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<map>
#define INF 0x3f3f3f3f

using namespace std;

char s[1000000];
int vis[100];
int main()
{
    int T,a;
    while(~scanf("%d",&T))
    {
        while(T--)
        {
            long long sum=0;
            scanf("%s%d",s,&a);
            memset(vis,0,sizeof(vis));
            int len=strlen(s);
            int pos=0;                        //左指向
            for(int i=0; i<len; i++)         //右指向
            {
                int x=s[i]-'a';
                vis[x]++;
                if(vis[x]>a)
                {
                    while(s[i]!=s[pos])
                    {
                        vis[s[pos]-'a']--;
                        pos++;
                    }
                    vis[s[pos]-'a']--;
                    pos++;
                }
                sum+=i-pos+1;
            }
            printf("%I64d\n",sum);
        }
    }
}
/*
 例如 abcabc 1

                 a       ab          abc        bca        .....
 sum+     1      2        3           3           3
                 a        b           c           a
					      ab         bc          ca
									abc         bca
 故15种
*/




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值