周赛一 ACdream 1199 排列组合

Description

There are n swords of different weights Wiand n heros of power Pi.

Your task is to find out how many ways the heros can carry the swords so that each hero carries exactly one sword.

Swords

Here are some rules:

(1) Every sword is carried by one hero and a hero cannot carry a sword whose weight is larger than his power.

(2) Two ways will be considered different if at least one hero carries a different sword.

Input

The first line of the input gives the number of test cases T(1 ≤ T ≤ 50).

Each case starts with a line containing an integer n (1 ≤ n ≤ 105) denoting the number of heros and swords.

The next line contains n space separated distinct integers denoting the weight of swords.

The next line contains n space separated distinct integers denoting the power for the heros.

The weights and the powers lie in the range [1, 109].

Output

For each case, output one line containing "Case #x: " followed by the number of ways those heros can carry the swords.

This number can be very big. So print the result modulo 1000 000 007.

Sample Input

3
5
1 2 3 4 5
1 2 3 4 5
2
1 3
2 2
3
2 3 4
6 3 5

Sample Output

Case #1: 1
Case #2: 0
Case #3: 4

#include<iostream>
#include<cstring>
#include<cstdio>
#include<cstdlib>
#include<algorithm>

using namespace std;

int p[100010];
int T,n;
int a[100010];
int main()
{
    while(~scanf("%d",&T))
    {
        int Case=0;
        while(T--)
        {
            Case++;
            scanf("%d",&n);
            for(int i=0; i<n; ++i)
                scanf("%d",&a[i]);
            for(int j=0; j<n; ++j)
                scanf("%d",&p[j]);
            sort(a,a+n);
            sort(p,p+n);
           long long sum=1;
         int j=0;
           for(int i=0;i<n;i++) //组合数 求排列组合的种类
		   {
		   	while(j<n&&a[j]<=p[i])j++;
		   	sum=sum*(j-i)%1000000007;
		   }
            printf("Case #%d: %lld\n",Case,sum%1000000007);
        }
    }
}

/*
struct node
{
    int power;
    int num;
} p[100010];
int T,n;
int a[100010];
int cmp(node p1,node p2)
{
    return p1.power<p2.power;
}
int main()
{
    while(~scanf("%d",&T))
    {
        int Case=0;
        while(T--)
        {
            Case++;
            scanf("%d",&n);
            for(int i=0; i<n; ++i)
                scanf("%d",&a[i]);
            for(int j=0; j<n; ++j)
            {
                scanf("%d",&p[j].power);
                p[j].num=0;
            }
            sort(a,a+n);
            sort(p,p+n,cmp);
            int j=0;

            for(int i=0; i<n; ++i)  //组合数
            {
                if(i==0)
                {
                    for(; j<n; j++)
                    {
                        if(p[i].power>=a[j])
                            p[i].num++;
                        else
                            break;
                    }
                }
                else
                {
                    if(p[i-1].power==p[i].power)
                    {
                        p[i].num=p[i-1].num-1;
                    }
                    else
                    {
                        p[i].num=p[i-1].num;
                        for(; j<n; j++)
                        {
                            if(p[i].power>=a[j])
                                p[i].num++;
                            else
                            {
                                p[i].num-=1;
                                break;
                            }
                        }
                        if(j==n)
                            p[i].num-=1;
                    }
                }
            }
            long long int sum=1;
            for(int i=0; i<n; i++)
            {
                sum*=p[i].num%1000000007;
                sum%=1000000007;   //勿漏<span id="transmark"></span>
                if(sum==0)
                    break;
            }
            printf("Case #%d: %lld\n",Case,sum%1000000007);
        }
    }
}
*/


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值