HDU 5475 网赛

An easy problem

Time Limit: 8000/5000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 322    Accepted Submission(s): 170


Problem Description
One day, a useless calculator was being built by Kuros. Let's assume that number X is showed on the screen of calculator. At first, X = 1. This calculator only supports two types of operation.
1. multiply X with a number.
2. divide X with a number which was multiplied before.
After each operation, please output the number X modulo M.
 

Input
The first line is an integer T( 1T10 ), indicating the number of test cases.
For each test case, the first line are two integers Q and M. Q is the number of operations and M is described above. ( 1Q105,1M109 )
The next Q lines, each line starts with an integer x indicating the type of operation.
if x is 1, an integer y is given, indicating the number to multiply. ( 0<y109 )
if x is 2, an integer n is given. The calculator will divide the number which is multiplied in the nth operation. (the nth operation must be a type 1 operation.)

It's guaranteed that in type 2 operation, there won't be two same n.
 

Output
For each test case, the first line, please output "Case #x:" and x is the id of the test cases starting from 1.
Then Q lines follow, each line please output an answer showed by the calculator.
 

Sample Input
  
  
1 10 1000000000 1 2 2 1 1 2 1 10 2 3 2 4 1 6 1 7 1 12 2 7
 

Sample Output
  
  
Case #1: 2 1 2 20 10 1 6 42 504 84
 

Source
 

Recommend
hujie   |   We have carefully selected several similar problems for you:   5483  5482  5481  5480  5479 
 
题意:输入为a=1时 结果乘上b
a=2 时 结果除以第b个输入的b.
这道题以为是大数运算呢,结果怎么交都TLE
一细想原来是就是普通的运算.


#include <bits/stdc++.h>

using namespace std;

const int maxn = 1e5+10;

int vis[1000000];
long long a[maxn];
int flag[maxn],b[maxn];

int main()
{
    int t,q;
    long long m;
    int cas = 1;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%I64d",&q,&m);
        long long result = 1;
		printf("Case #%d:\n",cas++);
        for(int i = 1; i <= q; i++)
        {
            scanf("%d%I64d",&b[i],&a[i]);
            if(b[i] == 1)
                result = result*a[i]%m;
            else if(b[i] == 2)
            {
                a[a[i]]=1;
                a[i]=1;
                result = 1;
                for(int j = 1; j < i; j++)
                {
                        result = result*a[j]%m;
                }
            }
             printf("%d\n",result);
        }

    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值