HDU 2577 dp 输入法切换最小次 两数组维护两种状态

How to Type

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5201    Accepted Submission(s): 2326


Problem Description
Pirates have finished developing the typing software. He called Cathy to test his typing software. She is good at thinking. After testing for several days, she finds that if she types a string by some ways, she will type the key at least. But she has a bad habit that if the caps lock is on, she must turn off it, after she finishes typing. Now she wants to know the smallest times of typing the key to finish typing a string.
 

Input
The first line is an integer t (t<=100), which is the number of test case in the input file. For each test case, there is only one string which consists of lowercase letter and upper case letter. The length of the string is at most 100.
 

Output
For each test case, you must output the smallest times of typing the key to finish typing this string.
 

Sample Input
  
  
3 Pirates HDUacm HDUACM
 

Sample Output
 
 
8 8 8
Hint
The string “Pirates”, can type this way, Shift, p, i, r, a, t, e, s, the answer is 8. The string “HDUacm”, can type this way, Caps lock, h, d, u, Caps lock, a, c, m, the answer is 8 The string "HDUACM", can type this way Caps lock h, d, u, a, c, m, Caps lock, the answer is 8 用两个a,b数组分别记录Caps Lock开与关时打印第i个字母的最少操作步骤; 而对于第i个字母的大小写还要分开讨论: Ch[i] 为小写: a[i]=min(a[i-1]+1,b[i-1]+2);不开灯直接字母,开灯则先关灯再按字母,最后保持不开灯; b[i]=min(a[i-1]+2,b[i-1]+2);不开灯则先按字母再开灯,开灯则Shift+字母(比关灯,按字母再开灯节省步数),最后保持 开灯; Ch[i]为大写: a[i]=min(a[i-1]+2,b[i-1]+2); b[i]=min(a[i-1]+2,b[i-1]+1)
#include<bits/stdc++.h>
using namespace std;
char s[1000];
int dp1[1000];
int dp2[1000];
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
       while(n--)
       {
           scanf("%s",s);
           int len=strlen(s);
           memset(dp1,0,sizeof(dp1));
           memset(dp2,0,sizeof(dp2));
           dp2[0]=1;             //大写锁定状态
           dp1[0]=0;             //普通
           for(int i=1;i<=len;i++)
           {
               if(s[i-1]>='a'&&s[i-1]<='z')
               {
                   dp1[i]+=min(dp1[i-1]+1,dp2[i-1]+2);
                   dp2[i]+=min(dp1[i-1]+2,dp2[i-1]+2);
               }
               else
               {
                   dp1[i]+=min(dp1[i-1]+2,dp2[i-1]+2);
                   dp2[i]+=min(dp1[i-1]+2,dp2[i-1]+1);
               }
               //cout<<dp1[i]<<dp2[i];
           }
           int Min=min(dp1[len],dp2[len]+1);
           printf("%d\n",Min);
       }
    }
    return 0;
}

 
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值