搜索 || 深搜(水洼)

C - Lake Counting

 Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors. 
Given a diagram of Farmer John's field, determine how many ponds he has.
Input
* Line 1: Two space-separated integers: N and M 
* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.

Output
* Line 1: The number of ponds in Farmer John's field.
Sample Input
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.
Sample Output
3
Hint
OUTPUT DETAILS: 
There are three ponds: one in the upper left, one in the lower left,and one along the right side.

#include<iostream>
#include<stdio.h>
#include<algorithm>
#include<memory.h>
#include<queue>
using namespace std;
int n,m;
int ans;
char a[105][105];
int d[3]={0,1,-1};

void dfs(int x,int y){
	a[x][y]='.';
	int nx,ny;
		for(int i=0;i<3;i++){
			for(int j=0;j<3;j++){
				nx=x+d[i];
				ny=y+d[j];
				if(a[nx][ny]=='W')dfs(nx,ny);
			}
		}
}
int main(){
	while(~scanf("%d%d",&n,&m)){
		char c;
		for(int i=0;i<n;i++){
			for(int j=0;j<m;j++){
				scanf("%c",&c);
				if(c=='\n')j--;
				else a[i][j]=c;
			}
		}
		ans=0;
		for(int i=0;i<n;i++){
			for(int j=0;j<m;j++){
				if(a[i][j]=='W'){
					ans++;
					dfs(i,j);
				}
			}
		}
		printf("%d\n",ans);
		
	}
	
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

bekote

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值