C - Lake Counting
Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors.Given a diagram of Farmer John's field, determine how many ponds he has.
Input
* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.
Output
* Line 1: The number of ponds in Farmer John's field.
Sample Input
W........WW. .WWW.....WWW ....WW...WW. .........WW. .........W.. ..W......W.. .W.W.....WW. W.W.W.....W. .W.W......W. ..W.......W.Sample Output
3
Hint
OUTPUT DETAILS:
There are three ponds: one in the upper left, one in the lower left,and one along the right side.
#include<iostream>
#include<stdio.h>
#include<algorithm>
#include<memory.h>
#include<queue>
using namespace std;
int n,m;
int ans;
char a[105][105];
int d[3]={0,1,-1};
void dfs(int x,int y){
a[x][y]='.';
int nx,ny;
for(int i=0;i<3;i++){
for(int j=0;j<3;j++){
nx=x+d[i];
ny=y+d[j];
if(a[nx][ny]=='W')dfs(nx,ny);
}
}
}
int main(){
while(~scanf("%d%d",&n,&m)){
char c;
for(int i=0;i<n;i++){
for(int j=0;j<m;j++){
scanf("%c",&c);
if(c=='\n')j--;
else a[i][j]=c;
}
}
ans=0;
for(int i=0;i<n;i++){
for(int j=0;j<m;j++){
if(a[i][j]=='W'){
ans++;
dfs(i,j);
}
}
}
printf("%d\n",ans);
}
return 0;
}