POJ - 3273

                                                                     Monthly Expense  

Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤ moneyi ≤ 10,000) that he will need to spend each day over the next N (1 ≤ N ≤ 100,000) days.

FJ wants to create a budget for a sequential set of exactly M (1 ≤ MN) fiscal periods called "fajomonths". Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.

FJ's goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.

Input
Line 1: Two space-separated integers: N and M
Lines 2.. N+1: Line i+1 contains the number of dollars Farmer John spends on the ith day
Output
Line 1: The smallest possible monthly limit Farmer John can afford to live with.
Sample Input
7 5
100
400
300
100
500
101
400
Sample Output
500
Hint
If Farmer John schedules the months so that the first two days are a month, the third and fourth are a month, and the last three are their own months, he spends at most $500 in any month. Any other method of scheduling gives a larger minimum monthly limit.

题意:你有约翰N次的花费情况,若这些是约翰M个月的花费,求约翰每月最小限额。    

思路:直接二分最小限额,左端点为N次花费的最大值,右端点为N次花费的总数。

代码参考:            
#include <iostream>
#include<cstdio>
#include<cmath>
#include<algorithm>
#include<queue>
#include<stack>
#include<cstring>
#define max(a,b) a>b?a:b
#define ll long long
#define inf 0x3f3f3f3f

using namespace std;
int N,M,sum;
int s[100010];
int check(int mid)
{
    int ans=0,p=0;
    for(int i=0;i<N;i++)
    {
        p+=s[i];
        if(p<=mid&&p+s[i+1]>mid)
        {
            ans++;
            p=0;
        }
    }
    return ans;
}
int main()
{
    while(~scanf("%d%d",&N,&M))
    {
        sum=0;
        int maxx=0;
        memset(s,inf,sizeof(s));
        for(int i=0;i<N;i++)
        {
            scanf("%d",&s[i]);
            maxx=max(maxx,s[i]);
            sum+=s[i];
        }
        int l=maxx,r=sum,mid=(l+r)/2;
        while(l<r)
        {
            if(check(mid)>M) l=mid+1;
            else
                r=mid;
            mid=(l+r)/2;
        }
        printf("%d\n",mid);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值