【杭电oj5587】Array

Array

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 729    Accepted Submission(s): 347


Problem Description
Vicky is a magician who loves math. She has great power in copying and creating.
One day she gets an array {1}。 After that, every day she copies all the numbers in the arrays she has, and puts them into the tail of the array, with a signle '0' to separat.
Vicky wants to make difference. So every number which is made today (include the 0) will be plused by one.
Vicky wonders after 100 days, what is the sum of the first M numbers.
 

Input
There are multiple test cases.
First line contains a single integer T, means the number of test cases. (1T2103)
Next T line contains, each line contains one interger M.  (1M1016)
 

Output
For each test case,output the answer in a line.
 

Sample Input
  
  
3 1 3 5
 

Sample Output
  
  
1 4 7
 

Source
 

Recommend
hujie   |   We have carefully selected several similar problems for you:   5867  5866  5865  5864  5863 
 
不太明白。


#include<cstdio>
#include<iostream>
#include<cmath>
#include<cstring>
#include<algorithm>
#define LL long long
using namespace std;
const int N = 105;
LL num[N],sum[N];
void init(){
	num[1]=1;
	for(int i=2;i<=63;i++){
		num[i]=num[i-1]*2+1;
	} 
	sum[1]=1;
	for(int i=2;i<=63;i++){
		sum[i]=sum[i-1]*2+num[i-1]+1;
	}
}
int main(){
	int T;
	scanf("%d",&T);
	LL n;
	init();
	while(T--){
		scanf("%lld",&n);
		LL ans=0,count=0;
		while(n){
			int p=1;
			while(num[p]<=n){
				p++;
			}
			p--;
			ans+=sum[p]+num[p]*count;
			n-=num[p];
			if(n!=0){
				count++;
				ans+=count;
				n--;
			}
		}
		printf("%lld\n",ans);
	}
	return 0;
} 



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值