【bestcoder】Find Q(简单思维)

Find Q

 
 Accepts: 392
 
 Submissions: 780
 Time Limit: 2000/1000 MS (Java/Others)
 
 Memory Limit: 262144/131072 K (Java/Others)
Problem Description

Byteasar is addicted to the English letter 'q'. Now he comes across a string SS consisting of lowercase English letters.

He wants to find all the continous substrings of SS, which only contain the letter 'q'. But this string is really really long, so could you please write a program to help him?

Input

The first line of the input contains an integer T(1\leq T\leq10)T(1T10), denoting the number of test cases.

In each test case, there is a string SS, it is guaranteed that SS only contains lowercase letters and the length of SS is no more than 100000100000.

Output

For each test case, print a line with an integer, denoting the number of continous substrings of SS, which only contain the letter 'q'.

Sample Input
2
qoder
quailtyqqq
Sample Output
1
7

本题想很好想,就是注意一下数据类型用 long long 型就好了,看似不超int 实则超int。

#include<cstdio>
#include<iostream>
#include<cstring>
#include<cmath>
#include<algorithm>
#define LL long long 
using namespace std;
const int N = 100000+20;
char S[N];
int main(){
	int T;
	scanf("%d",&T);
	while(T--){
		scanf("%s",S);
		LL cnt=0,ans=0;
		int L=strlen(S);
		for(int i=0;i<=L;i++){
			if(S[i]=='q'){
				cnt++;
			}
			else if(S[i]!='q'&&S[i-1]=='q'){
				for(int j=cnt;j>=1;j--){
					ans+=j;
				}
				cnt=0;
			}
		}
		printf("%lld\n",ans);
	}
	return 0;
} 



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值