【5907 Find Q】

Problem Description
Byteasar is addicted to the English letter ‘q’. Now he comes across a string S consisting of lowercase English letters.

He wants to find all the continous substrings of S, which only contain the letter ‘q’. But this string is really really long, so could you please write a program to help him?

Input
The first line of the input contains an integer T(1≤T≤10), denoting the number of test cases.

In each test case, there is a string S, it is guaranteed that S only contains lowercase letters and the length of S is no more than 100000.

Output
For each test case, print a line with an integer, denoting the number of continous substrings of S, which only contain the letter ‘q’.

Sample Input
2
qoder
quailtyqqq

Sample Output
1
7

#include<cstdio>
#include<cstring>
using namespace std;
char st[100011];
int main()
{
    int T,i,nl;
    long long sum,ans;
    scanf("%d",&T);
    while(T--)
    {
        ans = 0;
        scanf("%s",st);
        nl = strlen(st);
        for(i = 0 ; i < nl ; i++)
        {
            sum = 0;
            while(st[i] == 'q'){
                 sum++;
                 i++;
                 if(i == nl)
                    break;
            }
                ans += sum * (sum + 1) / 2;
        }
        printf("%lld\n",ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值