PAT甲级1001 A+B Format

 

1001 A+B Format (20 分)

Calculate a+b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

计算a+b并输出标准格式的和——也就是说,数字必须用逗号分隔成三组(除非少于四位数)。

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −10^​6​​≤a,b≤10​^6​​. The numbers are separated by a space.

输入规格:
每个输入文件包含一个测试用例。每个案件包含两个整数a和b,−10^6≤a,b≤10^6。这些数字用空格隔开。

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

输出规范:
对于每个测试用例,您应该在一行中输出a和b的和。总和必须用标准格式书写。

Sample Input:

-1000000 9

Sample Output:

-999,991

本来是想用 求商取余的办法写的,但是取余过程中如果开头是0就会出错,像下面这样

后来想到将整型转为字符串型会比较好,to_string()函数在code block中总是报未声明,没有找到原因,但是在PAT中成功了

#include <iostream>
using namespace std;
int main() {
    int a, b;
    cin >> a >> b;
    string s = to_string(a + b);
    int len = s.length();
    for (int i = 0; i < len; i++) {
        cout << s[i];
        if (s[i] == '-') continue;
        if ((i + 1) % 3 == len % 3 && i != len - 1) cout << ",";
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值