【pat】1001 a+b format

Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).
Input Specification:
Each input file contains one test case. Each case contains a pair of integers a and b where −10​6​​≤a,b≤10​6​​. The numbers are separated by a space.
Output Specification:
For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:
    -1000000 9
Sample Output:
    -999,991
#include<iostream>
#include<iomanip>
/*setw(n)用法: 通俗地讲就是预设宽度
setfill(char c) 用法 : 就是在预设宽度中如果已存在没用完的宽度大小,则用设置的字符c填充如 cout<<setfill(‘@‘)<<setw(5)<<255<<endl;
setbase(int n) : 将数字转换为 n 进制.
...
*/
using namespace std;
int main()
{
  long int a=0,b=0;
  int c;
  if(a<-1000000|| b>1000000){return 0;}
  cin>>a>>b;
  c=a+b;
  
  if(c<0){
  	c=-c;
	if(c/1000000)
		cout<<-c/1000000<<","<<right<<setw(3)<<setfill('0')<<c/1000%1000<<","<<right<<setw(3)<<setfill('0')<<c%1000<<endl;
		//
    else if(c/1000)
    	cout<<-c/1000<<","<<right<<setw(3)<<setfill('0')<<c%1000<<endl;
    else
      cout<<-c;
  }
  else{
  	if(c/1000000)
		cout<<c/1000000<<","<<right<<setw(3)<<setfill('0')<<c/1000%1000<<","<<right<<setw(3)<<setfill('0')<<c%1000<<endl;
    else if(c/1000)
    	cout<<c/1000<<","<<right<<setw(3)<<setfill('0')<<c%1000<<endl;
    else
      cout<<c;	
  }
  return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值