Problem B

Problem 13 » Problem B 查看标程

Description

Given a string containing only 'A' - 'Z', we could encode it using the following method:

1. Each sub-string containing k same characters should be encoded to "kX" where "X" is the only character in this sub-string.

2. If the length of the sub-string is 1, '1' should be ignored.

INPUT

The first line contains an integer N (1 <= N <= 100) which indicates the number of test cases. The next N lines contain N strings. Each string consists of only 'A' - 'Z' and the length is less than 10000.

OUTPUT

For each test case, output the encoded string in a line.

SAMPLE INPUT

3
ABC
ABBCCC
ACB

SAMPLE OUTPUT

ABC
A2B3C
ACB

我的代码(有点复杂了):

#include<iostream>
using namespace std;
int main()
{
    char s[10001];
 int i,t,num;
 cin>>t;
 while(t--)
 {
  cin>>s;
   int len=strlen(s);
   num=1;
   char l=s[0];
   for(i=1;i<len;i++)
   {
  if(l==s[i])
      num++;
  else
  {
    if(num==1)
     cout<<l;
    else
    {
     cout<<num<<l;
        num=1;
      
    }
   
  }
        l=s[i];
   }
   if(num==1)
   cout<<l;
   else
  cout<<num<<l;
  
   cout<<endl;
 }
}

 

系统标程:

#include<iostream>
using namespace std;
#include<cstring>
int main()
{
 int n,len,j,m=1;
 cin>>n;
 char s[10001];
 while(n--)

 {
  cin>>s;
  len=strlen(s);
  for(j=0;j<len;j++)
  {
   if(s[j]!=s[j+1])
   {
    if(m>1)
     cout<<m;
    cout<<s[j];
    m=1;
   }
   if(s[j]==s[j+1])
    m++;
  }
  cout<<endl;
 }
 return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值