HDU3555Bomb数位DP入门题目

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=3555

Bomb

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 6448    Accepted Submission(s): 2242


Problem Description
The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence "49", the power of the blast would add one point.
Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?
 

Input
The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.

The input terminates by end of file marker.
 

Output
For each test case, output an integer indicating the final points of the power.
 

Sample Input
  
  
3 1 50 500
 

Sample Output
  
  
0 1 15
Hint
From 1 to 500, the numbers that include the sub-sequence "49" are "49","149","249","349","449","490","491","492","493","494","495","496","497","498","499", so the answer is 15.
 

#include<iostream>
#include<cstring>
#include<cstdio>
#include<cmath>
using namespace std;

long long  dp[33][3];
long long  DP(long long N)
{
    int bit[33];
            N++;
    long long sum=0;
    int len=0;
        while(N){
            bit[++len]=N%10;
            N/=10;
        }
        bit[len+1]=0;
        bool flag=0;
        for(int i=len;i>=1;i--){
            sum+=dp[i-1][2]*bit[i];
            if(!flag&&bit[i]>4)  sum+=dp[i-1][1];
            if(flag)    sum+=dp[i-1][0]*bit[i];
            if(bit[i+1]==4&&bit[i]==9)  flag=1;
        }
        return sum;
}
void init()
{
    memset(dp,0,sizeof(dp));dp[0][0]=1;
    for(int i=1;i<=20;i++){
        dp[i][0]=dp[i-1][0]*10-dp[i-1][1];
        dp[i][1]=dp[i-1][0];
        dp[i][2]=dp[i-1][1]+dp[i-1][2]*10;
    }
}
int main()
{
    init();
    int T;
    long long x;
    scanf("%d",&T);
    while(T--){
         cin>>x;
        cout<<DP(x)<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值