1084 - Deer-Proof Fence

Uncle Magnus has planted some young saplings on his farm as part of his reforestation project. Unfortunately, deer like to eat tender sapling shoots and leaves, making it necessary to build protective fences around them. Since deer and other sapling nibblers can reach partway over the fence, every fence must lie at least a minimum distance (a margin) from each sapling.

Deer-proof fencing is quite expensive, so Uncle Magnus wants to minimize the total length of fencing used. Your job is to write a program that computes the minimum length of fencing that is required to enclose and protect the saplings. Fences may include both straight and curved segments. You may design a single fence that encloses all saplings or multiple fences that enclose separate groups of saplings.

Figure 6 shows two example configurations, each consisting of three saplings with different margin requirements. In the top configuration, which corresponds to the first sample input, the minimum-length solution consists of two separate fences. In the bottom configuration, which corresponds to the second sample input, the minimum-length solution consists of a single fence.

\epsfbox{p4450.eps}

Figure 6: Deer-proof fences.

Input 

The input consists of multiple test cases. The first line of each test case contains integers N (0 < N$ \le$9), which is the number of saplings, and M (0 < M$ \le$200), which is the margin required around each sapling. This line is followed by N additional lines. Each of these N lines contains two integers x and y that describe the Cartesian coordinates of a sapling ( x|$ \le$100 and y|$ \le$100). No two saplings are in the same location. For simplicity the saplings can all be considered as points and the thickness of deer-proof fences can be considered zero.

The last test case is followed by a line containing two zeros.

Output 

For each test case, print the case number (starting with 1) followed by the minimum total length of fencing required to protect the saplings with the given margin. Print the length with two digits to the right of the decimal point. Follow the format of the sample output.

Sample Input 

3 2 
0 0 
2 0 
10 0 
3 4 
0 0 
2 0 
10 0 
0 0

Sample Output 

Case 1: length = 29.13 
Case 2: length = 45.13






#include<iostream>
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<math.h>
#include<algorithm>
using namespace std;
struct node
{
	int x,y;
}tmp[50];
int x[50],y[50],z[50];
int n,M;
double f[1200];
double const pi=acos(-1.0);

int cmp(node a,node b)
{
	if(a.x!=b.x)
		return a.x<b.x;
	return a.y<b.y;
}

int cross(int i,int j,int k)
{
	int x1=tmp[j].x-tmp[i].x;
	int y1=tmp[j].y-tmp[i].y;
	int x2=tmp[k].x-tmp[j].x;
	int y2=tmp[k].y-tmp[j].y;
	return x1*y2-x2*y1;
}

double sqr(int x)
{
	return x*x;
}

double dist(int i,int j)
{
	return sqrt(sqr(tmp[i].x-tmp[j].x) + sqr(tmp[i].y-tmp[j].y));
}

double get(int opt)
{
	int m=0;
	for(int i=0;i<n;i++)
		if(opt&(1<<i))
		{
			tmp[++m].x=x[i];
			tmp[m].y=y[i];
		}
	if(m==1)
		return pi*M*2;
	sort(tmp+1,tmp+m+1,cmp);
	int h=1,t=1;
	z[1]=1;
	for(int i=2;i<=m;i++)
	{
		while(h<t&&(cross(z[t-1],z[t],i)<0))
			t--;
		z[++t]=i;
	}
	for(int i=m-1;i;i--)
	{
		while(h<t&&(cross(z[t-1],z[t],i)<0))
			t--;
		z[++t]=i;
	}
	double ans=0;
	for(int i=1;i<t;i++)
		ans+=dist(z[i],z[i+1]);
	return ans+pi*M*2;
}

int main()
{
	int test=0;
	while(scanf("%d %d\n",&n,&M)&&n)
	{
		for(int i=0;i<n;i++)
			scanf("%d %d\n",&x[i],&y[i]);
		for(int i=1;i<1<<n;i++)
			f[i]=get(i);
		for(int i=1;i<1<<n;i++)
			for(int j=i;j;j=(j-1)&i)
				if((i&j)==j)
					f[i]=min(f[i],f[i-j]+f[j]);
		printf("Case %d: length = %.2lf\n",++test,f[(1<<n)-1]);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值