HDU 1027 Ignatiusand the Princess II

Ignatiusand the Princess II

Time Limit: 2000/1000 MS (Java/Others)    MemoryLimit: 65536/32768 K (Java/Others)
Total Submission(s): 2675    Accepted Submission(s): 1622


Problem Description

Now ourhero finds the door to the BEelzebub feng5166. He opens the door and findsfeng5166 is about to kill our pretty Princess. But now the BEelzebub has tobeat our hero first. feng5166 says, "I have three question for you, if youcan work them out, I will release the Princess, or you will be my dinner,too." Ignatius says confidently, "OK, at last, I will save thePrincess."

"Now I will show you the first problem." feng5166 says, "Given asequence of number 1 to N, we define that 1,2,3...N-1,N is the smallestsequence among all the sequence which can be composed with number 1 to N(eachnumber can be and should be use only once in this problem). So it's easy to seethe second smallest sequence is 1,2,3...N,N-1. Now I will give you two numbers,N and M. You should tell me the Mth smallest sequence which is composed withnumber 1 to N. It's easy, isn't is? Hahahahaha......"
Can you help Ignatius to solve this problem?

 

 

Input

The inputcontains several test cases. Each test case consists of two numbers, N andM(1<=N<=1000, 1<=M<=10000). You may assume that there is always asequence satisfied the BEelzebub's demand. The input is terminated by the endof file.

 

 

Output

For eachtest case, you only have to output the sequence satisfied the BEelzebub'sdemand. When output a sequence, you should print a space between two numbers,but do not output any spaces after the last number.

 

 

Sample Input

6 4

11 8

 

 

Sample Output

1 2 3 5 6 4

1 2 3 4 5 6 7 9 8 11 10

 

 

Author

Ignatius.L

 

题目大意:给定一个序列(递增有序的序列),输出这个序列第M小的序列;

 

解题思路:其实就是求序列的全排列,按字典序排列,可以使用stl中的next_permutation进行全排列操作;

 

#include <iostream>
#include <cstdio>
#include <algorithm>
#define nMax 1024
using namespace std;

int a[nMax];
int main(int argc, char *argv[])
{
    int n,m;
    while(cin>>n>>m)
    {
        for(int i=1; i<=n; i++)
        {
            a[i]=i;
        }
        for(int i=1; i<=m-1; i++)
        {
            next_permutation(a+1,a+n+1);
        }
        for(int i=1; i<=n-1; i++)
        {
            cout<<a[i]<<" ";
        }
        cout<<a[n]<<endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值