Java程序练习-Red and Black

http://poj.grids.cn/practice/1979/
http://poj.grids.cn/practice/3866/

Red and Black
时间限制: 1000ms内存限制: 65536kB
描述
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

输入
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.

输出
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
样例输入
6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0
样例输出
45
59
6
13
参考代码

import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
public class Main {
	public static char map[][];
	public static int row;
	public static int col;
	public static int steps;
	public static int ds[][]=new int[][]{{1,0},{-1,0},{0,1},{0,-1}};
	public static void main(String[] args) throws IOException {
		BufferedReader cin = new BufferedReader(new InputStreamReader(System.in));
		while(true){
			String dn[] = cin.readLine().split(" ");
			col = Integer.parseInt(dn[0]);
			row = Integer.parseInt(dn[1]);
			if(0 == col && 0 == row)
				break;
			map = new char[row][col];
			int si = 0,sj = 0;
			for(int i = 0;i < row;++ i){
				String sline = cin.readLine();
				for(int j = 0;j < col;++ j){
					map[i][j] = sline.charAt(j);
					if(map[i][j] == '@'){
						si = i;
						sj = j;
					}
				}
			}
			steps = 1;
			movesteps(si,sj);
			System.out.println(steps);
		}
	}
	private static void movesteps(int si, int sj) {
		for(int i = 0;i < 4;++ i){
			int sx = si+ds[i][0],sy = sj+ds[i][1];
			if(check(sx,sy)){
				map[sx][sy] = '1';
				movesteps(sx,sy);
				steps ++;
			}
		}
	}
	private static boolean check(int x, int y) {
		if(x >= 0&&x < row&&y >= 0&&y < col&&map[x][y] == '.')
			return true;
		return false;
	}
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值