ZOJ 2165 Red and Black(DFS)

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.


Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and HW and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

  • '.' - a black tile
  • '#' - a red tile
  • '@' - a man on a black tile(appears exactly once in a data set)


Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).


Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0


Sample Output

45
59
6
13

分析:迷宫中,在@处最多可以走多少步(@处也算一步),典型的dfs。

代码如下:

#include<stdio.h>
#include<string.h>
int w,h,count;
char map[22][22];

int dfs(int x,int y)
{
	if(map[x][y]=='#'||x<1||x>w||y<1||y>h)//这些情况下不能走 
	return 0;
	else
	{
		map[x][y]='#';//把能走的地方变为不能走的 
		return dfs(x,y+1)+dfs(x+1,y)+dfs(x,y-1)+dfs(x-1,y)+1;//搜索四个方向 ,步数加一 
	}
}
int main()
{
	int i,j,x,y;
	while(scanf("%d%d",&h,&w),w!=0||h!=0)
	{
		count=0;
		for(i=1;i<=w;i++)
		{
			getchar();
			for(j=1;j<=h;j++)
			{
				scanf("%c",&map[i][j]);
				if(map[i][j]=='@')
				{
					x=i;
					y=j;
				}
			}
		}
		count=dfs(x,y);
		printf("%d\n",count);
	}
	return 0;
} 

 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值