ZOJ 2165 Red and Black 详解

大家好,今天记录的是ZOJ的2165题

WA了好几次,后来一次是Presentation Error,发现是输出之后没有换行,加上之后就AC了。

题目如下(建议忽视)

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.


Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and HW and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

  • '.' - a black tile
  • '#' - a red tile
  • '@' - a man on a black tile(appears exactly once in a data set)


Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).


Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0


Sample Output

45
59
6
13

//摘自ZOJ (pintia.cn)

翻译结果

有一个长方形的房间,覆盖着方形瓷砖。每个磁贴的颜色为红色或黑色。一个男人站在一块黑色的瓷砖上。从图块中,他可以移动到四个相邻图块之一。但他不能在红色的瓷砖上移动,他只能在黑色的瓷砖上移动。

编写一个程序来计算他可以通过重复上述动作达到的黑色瓷砖的数量。


输入

输入由多个数据集组成。数据集以包含两个正整数W和H的行开始;W 和 H 分别是 x 和 y 方向上的图块数。W 和 H 不超过 20。

数据集中还有 H 行,每行都包含 W 个字符。每个字符表示磁贴的颜色,如下所示。

  • '.' - 黑色瓷砖
  • “#” - 红色磁贴
  • '@' - 黑色图块上的男人(在数据集中只出现一次)


输出

对于每个数据集,您的程序应输出一行,其中包含他从初始磁贴(包括其自身)可以到达的磁贴数。

简单分析

一道挺简单的DFS,看到一些大佬说是模板题,好像还真是,对于我这个菜鸡来说也不是很难。

思路:

先排除不能走的情况,再把能走的地方标记为不能走,同时向四个方向深入,递归一下就好了。

代码

//并非原创,结合了多位大佬的智慧结晶,非常感谢

#include<stdio.h>
#include<string>
#include <iostream>
using namespace std;
int w, h, countt;
char map[22][22];

int DFS(int x, int y)
{
	if (map[x][y] == '#' || x<1 || x>w || y<1 || y>h) //先排除边界
		return 0;
	else
	{
		map[x][y] = '#';         //把能走的地方标记为不能走的 
		return DFS(x, y + 1) + DFS(x + 1, y) + DFS(x, y - 1) + DFS(x - 1, y) + 1;    //向四个方向深入,再加上初始位置的一块
	}
}
int main()
{
	int i, j, x, y;
	while (cin >>h>>w, w != 0 || h != 0)
	{
		countt = 0;
		for (i = 1; i <= w; i++)
		{
			getchar();
			for (j = 1; j <= h; j++)
			{
				cin>> map[i][j];
				if (map[i][j] == '@')
				{
					x = i;
					y = j;
				}
			}
		}
		countt = DFS(x, y);
		cout<< countt<<endl;
	}
	return 0;
}

感谢您的观看,如有不正之处,敬请斧正

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

洋洋得意呀

您的鼓励是我最大的动力,谢谢您

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值