ZOJ 1151 Word Reversal (模拟)

For each list of words, output a line with each word reversed without changing the order of the words.


This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.

Input

You will be given a number of test cases. The first line contains a positive integer indicating the number of cases to follow. Each case is given on a line containing a list of words separated by one space, and each word contains only uppercase and lowercase letters.

Output

For each test case, print the output on one line.

Sample Input

1

3
I am happy today
To be or not to be
I want to win the practice contest

Sample Output

I ma yppah yadot
oT eb ro ton ot eb
I tnaw ot niw eht ecitcarp tsetnoc

题意描述:给出n串字符串,让其写一个n个字符串里的单词反转的程序(字符串只包含大小写字母和两个单词之间用一个空格隔开)。

分析:模拟一下过程就行,主要就是处理好字符串中最后一个单词和这道题的输出格式问题就OK啦。

代码如下:

#include<stdio.h>
#include<string.h>

int main()
{
	char s[1010],a[100];
	int i,len,j,k,k1;
	int t,n;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		getchar();//处理空行问题 
		while(n--)
		{
			gets(s);
			len=strlen(s);
			i=0;
			while(i<len)
			{
				j=i;k=0;
				while(s[j]!=' '&&s[j]!='\0')//把单词存储到数组a中,注意最后一个单词是'\0'不是空格了 
				{
					a[k++]=s[j++];
				}
				a[k]='\0';
				for(k1=k-1;k1>=0;k1--)
				printf("%c",a[k1]);//反转单词 
				if(j<len)
				printf("%c",s[j]);//输出空格 
				i=j+1;
			}
			printf("\n");
		}
		if(t) 
		printf("\n");
	}	
	return 0;
} 

 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值