SDUT——Mirror, Mirror on the Wall 解题报告

原题:

题目描述

        For most fonts, the lowercase letters b and d are mirror images of each other, as are the letters p and q. Furthermore, letters i, o, v, w, and x are naturally mirror images of themselves. Although other symmetries exists for certain fonts, we consider only those specifically mentioned thus far for the remainder of this problem.
 
      Because of these symmetries, it is possible to encode certain words based upon how those words would appear in the mirror. For example the word boxwood would appear as boowxod, and the word ibid as bidi. Given a particular sequence of letters, you are to determine its mirror image or to note that it is invalid.

输入

    The input contains a series of letter sequences, one per line, followed by a single line with the # character. Each letter sequence consists entirely of lowercase letters. 

输出

    For each letter sequence in the input, if its mirror image is a legitimate letter sequence based upon the given symmetries, then output that mirror image. If the mirror image does not form a legitimate sequence of characters, then output the word INVALID. 

示例输入

boowxod
bidi
bed
bbb
#

示例输出

boxwood
ibid
INVALID
ddd

 

分析:

我就会水一发~~

原码:

#include<stdio.h>
#include<iostream>
#include<string.h>
using namespace std;
int main()
{
    char a[30];
    while(cin>>a)
    {
        int f=0;
        if(strcmp(a,"#")==0)
            break;
        int l=strlen(a);
        for(int i=0; i<l; i++)
        {
            if((a[i]!='i')&&(a[i]!='o')&&(a[i]!='v')&&(a[i]!='w')&&(a[i]!='x')&&(a[i]!='b')&&(a[i]!='d')&&(a[i]!='p')&&(a[i]!='q'))
            {
                printf("INVALID\n");
                f=1;
                break;
            }
        }
        if(f==0)
        {
            for(int j=l-1; j>=0; j--)
            {
                if(a[j]=='i')
                    printf("i");
                else if(a[j]=='o')
                    printf("o");
                else if(a[j]=='v')
                    printf("v");
                else if(a[j]=='w')
                    printf("w");
                else if(a[j]=='x')
                    printf("x");
                else if(a[j]=='b')
                    printf("d");
                else if(a[j]=='p')
                    printf("q");
                else if(a[j]=='q')
                    printf("p");
                else if(a[j]=='d')
                    printf("b");
            }
            printf("\n");
        }
    }
    return 0;
}


 


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值