2405. Mirror, Mirror on the Wall

2405. Mirror, Mirror on the Wall

Description

For most fonts, the lowercase letters  b and  d are mirror images of each other, as are the letters  p and  q. Furthermore, letters  iovw, and  x  are naturally mirror images of themselves. Although other symmetries exists for certain fonts, we consider only those specifically mentioned thus far for the remainder of this problem.
Because of these symmetries, it is possible to encode certain words based upon how those words would appear in the mirror. For example the word  boxwood would appear as  boowxod, and the word  ibid as  bidi. Given a particular sequence of letters, you are to determine its mirror image or to note that it is invalid.

Input

The input contains a series of letter sequences, one per line, followed by a single line with the # character. Each letter sequence consists entirely of lowercase letters.

Output

For each letter sequence in the input, if its mirror image is a legitimate letter sequence based upon the given symmetries, then output that mirror image. If the mirror image does not form a legitimate sequence of characters, then output the word INVALID.

Sample Input

boowxod
bidi
bed
bbb
#

Sample Output

boxwood
ibid
INVALID
ddd

Problem Source

每周一赛第四场


// source code of submission 964045, Zhongshan University Online Judge System
#include <iostream>
#include <string>
#include <cstring>
using namespace std;

int main()
{
    string str;
    while (cin >> str)
    {
        if (str == "#")
            return 0;
        int len = str.length();
        bool b = true;
        for (int i = 0; i < len;i++)
        {
            if(str[i] == 'b')
                str[i] = 'd';
            else if(str[i] == 'd')
                str[i] = 'b';
            else if(str[i] == 'p')
                str[i] = 'q';
            else if(str[i] == 'q')
                str[i] = 'p';
            else if(str[i]!='i'&&str[i]!='o'&&str[i]!='v'&&str[i]!='w'&&str[i]!='x')
                 b = false;
        }
        if (b)
        {
            for (int j = len - 1;j >= 0;j--)
                cout << str[j];
            cout << endl;
        }
        else cout << "INVALID" << endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值