G - Mirror, Mirror on the Wall (分支判断+if)

For most fonts, the lowercase letters b and d are mirror images of each other, as are the letters p and q. Furthermore, letters i, o, v, w, and x are naturally mirror images of themselves. Although other symmetries exists for certain fonts, we consider only those specifically mentioned thus far for the remainder of this problem. Because of these symmetries, it is possible to encode certain words based upon how those words would appear in the mirror. For example the word boxwood would appear as boowxod, and the word ibid as bidi. Given a particular sequence of letters, you are to determine its mirror image or to note that it is invalid.

Input

The input contains a series of letter sequences, one per line, followed by a single line with the ‘#’ character. Each letter sequence consists entirely of lowercase letters.

Output

For each letter sequence in the input, if its mirror image is a legitimate letter sequence based upon the given symmetries, then output that mirror image. If the mirror image does not form a legitimate sequence of characters, then output the word ‘INVALID’. Sample Input

boowxod

bidi

bed

bbb

#

Sample Output

boxwood

ibid

INVALID

ddd

【解析】

就是输出镜面

但只讨论b d q p i o v w x

#include <bits/stdc++.h>
using namespace std;
stack<char> ans;
bool is_ok(char a)
{
	return a == 'b' || a == 'd' || a == 'i' || a == 'o' || a == 'v' || a == 'w' || a == 'x'||a=='p'||a=='q';
}
int main()
{
	char s[1010];
	while (~scanf("%s", s))
	{
		while (!ans.empty())ans.pop();
		if (s[0] == '#')break;
		int flag = 1;
		for (int i = 0; i < strlen(s); i++)
		{
			if (!is_ok(s[i]))
			{
				flag = 0;
				break;
			}
			else
			{
				if (s[i] == 'b')
					s[i] = 'd';
				else if (s[i] == 'd')
					s[i] = 'b';
				else if (s[i] == 'p')
					s[i] = 'q';
				else if (s[i] == 'q')
					s[i] = 'p';
				ans.push(s[i]);
			}
		}
		if (flag)
		{
			while (!ans.empty())
			{
				char c = ans.top();
				ans.pop();
				printf("%c", c);
			}
		}
		else printf("INVALID");
		printf("\n");
	}

	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值