群赛11.10 A Very Easy Triangle Counting Game

Problem G: A Very Easy Triangle Counting Game

Time Limit: 1 Sec   Memory Limit: 128 MB
Submit: 80   Solved: 31
[ Submit][ Status][ Web Board]

Description

Input

 

Output

 

Sample Input

3
1
4
6

Sample Output

Case #1: 0
Case #2: 8
Case #3: 32

HINT

#include <cstdio>
#include <cstring>
#include <queue>
#include <stack>
#include <algorithm>
#include <iostream>
using namespace std;
int solve(int n)
{
    if(n<3) return 0;
    if(n==3) return 1;
    if(n==4) return 8;
    if(n==5) return 35;
    if(n==6) return 32;
    int ans=0;
    ans = 5*n;
    return ans%20121111;
}
int main()
{
    freopen("in.txt","r",stdin);
    int cas,T=1;
    scanf("%d",&cas);
    while(cas--)
    {
        int n;
        scanf("%d",&n);
        printf("Case #%d: %d\n",T++,solve(n));
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值