九度oj 题目1035:找出直系亲属

题目描述:
    如果A,B是C的父母亲,则A,B是C的parent,C是A,B的child,如果A,B是C的(外)祖父,祖母,则A,B是C的grandparent,C是A,B的grandchild,如果A,B是C的(外)曾祖父,曾祖母,则A,B是C的great-grandparent,C是A,B的great-grandchild,之后再多一辈,则在关系上加一个great-。
输入:
    输入包含多组测试用例,每组用例首先包含2个整数n(0<=n<=26)和m(0<m<50), 分别表示有n个亲属关系和m个问题, 然后接下来是n行的形式如ABC的字符串,表示A的父母亲分别是B和C,如果A的父母亲信息不全,则用-代替,例如A-C,再然后是m行形式如FA的字符串,表示询问F和A的关系。
    当n和m为0时结束输入。
输出:
    如果询问的2个人是直系亲属,请按题目描述输出2者的关系,如果没有直系关系,请输出-。
    具体含义和输出格式参见样例.
样例输入:
3 2
ABC
CDE
EFG
FA
BE
0 0
样例输出:
great-grandparent
-
来源:

2009年浙江大学计算机及软件工程研究生机试真题

#include<iostream>

using namespace std;

int tree[1001]; //孩子节点 

int relation(int a, int b) { //计算层差以确定关系 
    int t = 1;
    while (tree[a] != -1) {
          if (tree[a] == b)
             return t;
           a = tree[a];
           ++t;
    }
    return -1;
}
 
int main()
{
    int n, m;
    while (cin >> n >> m && n && m) {
          for (int i=0; i!=1000; ++i)
             tree[i] = -1;
       string s;
       int a, b, c;
       while (n--) {
          cin >> s;
          a = s[0] - 'A';
          b = s[1] - 'A';
          c = s[2] - 'A';
          tree[b] = tree[c] = a; //
       }
       while (m--) {
             cin >> s;
             a = relation(s[0]-'A', s[1]-'A'); //a>0,前者为父母 
             b = relation(s[1]-'A', s[0]-'A');
             int  t = a>b?a:b;  //t为层差 
             if (t <= 0)
               cout << "-" << endl;
             else {
                  while (t > 2) {
                     cout << "great-";
                     --t;
                  }
                  if (t == 2) {
                    cout << "grand";
                        --t;
                  }
                  if (t == 1) {
                        if (a > 0) 
                        cout << "parent" << endl;
                       else
                        cout << "child" << endl;
                  }
             }//else  
       }//while m
    }
     return 0;
}
             


 
 
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值