HDU 找出直系亲属 (dfs+vector)

37 篇文章 0 订阅


Problem Description

如果A,B是C的父母亲,则A,B是C的parent,C是A,B的child,如果A,B是C的(外)祖父,祖母,则A,B是C的grandparent,C是A,B的grandchild,如果A,B是C的(外)曾祖父,曾祖母,则A,B是C的great-grandparent,C是A,B的great-grandchild,之后再多一辈,则在关系上加一个great-。

Input

输入包含多组测试用例,每组用例首先包含2个整数n(0<=n<=26)和m(0<m<50), 分别表示有n个亲属关系和m个问题, 然后接下来是n行的形式如ABC的字符串,表示A的父母亲分别是B和C,如果A的父母亲信息不全,则用-代替,例如A-C,再然后是m行形式如FA的字符串,表示询问F和A的关系。
当n和m为0时结束输入。

Output

如果询问的2个人是直系亲属,请按题目描述输出2者的关系,如果没有直系关系,请输出-。
具体含义和输出格式参见样例.

Sample Input

3 2
ABC
CDE
EFG
FA
BE
0 0

Sample Output

great-grandparent
-

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<vector>
using namespace std;
vector<int>vv[1111];
int ok,ans;
int dfs(int s,int e,int cnt)
{
	if(s==e) {
		ok=1;
		ans=cnt;
		return cnt;
	}
	for(int i=0;i<vv[s].size();i++) {
		if(ok) break;
		dfs(vv[s][i],e,cnt+1);
	}
	return 0;
}

int main()
{
	int n,m,i,j;
	char a,b,c;
	while(cin>>n>>m) {
		for(i=0;i<30;i++) vv[i].clear();
		if(n==0&&m==0) break;
		for(i=1;i<=n;i++) {
			cin>>a>>b>>c;
			if(b!='-') vv[a-'A'].push_back(b-'A');
			if(c!='-') vv[a-'A'].push_back(c-'A');
		}
		while(m--) {
			ok=0;ans=0;
			cin>>a>>b;
			dfs(a-'A',b-'A',0);
			if(ok) {
				while(ans>2) {
					cout<<"great-";
					ans--;
				} 
				if(ans==2) cout<<"grandchild";
				if(ans==1) cout<<"child";
				cout<<endl;
		    }
			else {
				dfs(b-'A',a-'A',0);
				if(ok) {
			    	while(ans>2) {
			    		cout<<"great-";
			    		ans--;
					}
					if(ans==2) cout<<"grandparent";
	     			if(ans==1) cout<<"parent";
			    	cout<<endl;
				} 
				else cout<<"-"<<endl;
			}
		}
	}
	return 0;
}



















  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值