1035.寻找直系亲属

题目描述:
如果A,B是C的父母亲,则A,B是C的parent,C是A,B的child,如果A,B是C的(外)祖父,祖母,则A,B是C的grandparent,C是A,B的grandchild,如果A,B是C的(外)曾祖父,曾祖母,则A,B是C的great-grandparent,C是A,B的great-grandchild,之后再多一辈,则在关系上加一个great-。
输入:
输入包含多组测试用例,每组用例首先包含2个整数n(0<=n<=26)和m(0<m<50), 分别表示有n个亲属关系和m个问题, 然后接下来是n行的形式如ABC的字符串,表示A的父母亲分别是B和C,如果A的父母亲信息不全,则用-代替,例如A-C,再然后是m行形式如FA的字符串,表示询问F和A的关系。
当n和m为0时结束输入。
输出:
如果询问的2个人是直系亲属,请按题目描述输出2者的关系,如果没有直系关系,请输出-。
具体含义和输出格式参见样例.
样例输入:
3 2
ABC
CDE
EFG
FA
BE
0 0
样例输出:
great-grandparent

-


并查集思想。

#include <iostream>
#include <vector>
#include <string>
#include <fstream>

using namespace std;

int CalcDistance(const vector<int> &ivec, int a, int b)
{
	int d = 0;
	while (a != -1)
	{
		if (a == b)
			return d;
		else
		{
			++d;
			a = ivec[a];
		}
	}
	return -1;
}

inline void Union_Set(vector<int> &ivec, int a, int b)
{
	ivec[b] = a;
}

void output(int d, bool flag)
{
	string str = (flag) ? "parent" : "child";

	if (d == 1)
		cout << str << endl;
	else if (d >= 2)
	{
		for (int i = 0; i < d - 2; ++i)
			cout << "great-";
		cout << "grand" << str << endl;
	}
	else
		return;
}

int main()
{
	int n, m;
	while (cin >> n >> m)
	{
		vector<int> ivec(26, -1);
		if (n == 0 && m == 0)
			break;
		for (int i = 0; i < n; ++i)
		{
			string str;
			cin >> str;
			if (str[1] != '-')
				Union_Set(ivec, str[0] - 'A', str[1] - 'A');
			if (str[2] != '-')
				Union_Set(ivec, str[0] - 'A', str[2] - 'A');
		}
		for (int i = 0; i < m; ++i)
		{
			string str;
			cin >> str;
			bool flag = false;
			int d1 = CalcDistance(ivec, str[0] - 'A', str[1] - 'A');
			int d2 = CalcDistance(ivec, str[1] - 'A', str[0] - 'A');
			int d = (d1 > d2) ? (flag = true, d1) : d2;
			if (d <= 0)
				cout << "-" << endl;
			else 
				output(d, flag);
		}
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值