PAT--1077. Kuchiguse

The Japanese language is notorious for its sentence ending particles. Personal preference of such particles can be considered as a reflection of the speaker’s personality. Such a preference is called “Kuchiguse” and is often exaggerated artistically in Anime and Manga. For example, the artificial sentence ending particle “nyan~” is often used as a stereotype for characters with a cat-like personality:

Itai nyan~ (It hurts, nyan~)
Ninjin wa iyada nyan~ (I hate carrots, nyan~)
Now given a few lines spoken by the same character, can you find her Kuchiguse?

Input Specification:

Each input file contains one test case. For each case, the first line is an integer N (2<=N<=100). Following are N file lines of 0~256 (inclusive) characters in length, each representing a character’s spoken line. The spoken lines are case sensitive.

Output Specification:

For each test case, print in one line the kuchiguse of the character, i.e., the longest common suffix of all N lines. If there is no such suffix, write “nai”.

Sample Input 1:
3
Itai nyan~
Ninjin wa iyadanyan~
uhhh nyan~
Sample Output 1:
nyan~
Sample Input 2:
3
Itai!
Ninjinnwaiyada T_T
T_T
Sample Output 2:
nai

题解

最长公共后缀。

#include <bits/stdc++.h>
using namespace std;

int n;
vector<string> lines;

int main(){

    cin >> n;
    cin.ignore();
    string s;
    int minlen = 300;
    for(int i = 0; i < n; ++i){
        getline(cin, s);
        minlen = min(minlen, (int)s.length());
        lines.push_back(string(s.rbegin(), s.rend()));
    }

    string ans;
    for(int i = 0; i < minlen; ++i){
        char ch = lines[0][i];
        bool flag = 0;
        for(int j = 0; j < lines.size(); ++j){
            if(lines[j][i] != ch){
                flag = 1;
                break;
            }
        }
        if(!flag) ans.push_back(ch);
        else{
            break;
        }
    }
    if(ans.empty()) cout << "nai" << endl; 
    else{
        string t = string(ans.rbegin(), ans.rend());
        cout << t << endl;
    }


    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值