Problem Description
Welcome to 2006'4 computer college programming contest!
Specially, I give my best regards to all freshmen! You are the future of HDU ACM! And now, I must tell you that ACM problems are always not so easy, but, except this one... Ha-Ha!
Give you an integer; your task is to output its reverse number. Here, reverse number is defined as follows:
1. The reverse number of a positive integer ending without 0 is general reverse, for example, reverse (12) = 21;
2. The reverse number of a negative integer is negative, for example, reverse (-12) = -21;
3. The reverse number of an integer ending with 0 is described as example, reverse (1200) = 2100.
Specially, I give my best regards to all freshmen! You are the future of HDU ACM! And now, I must tell you that ACM problems are always not so easy, but, except this one... Ha-Ha!
Give you an integer; your task is to output its reverse number. Here, reverse number is defined as follows:
1. The reverse number of a positive integer ending without 0 is general reverse, for example, reverse (12) = 21;
2. The reverse number of a negative integer is negative, for example, reverse (-12) = -21;
3. The reverse number of an integer ending with 0 is described as example, reverse (1200) = 2100.
Input
Input file contains multiple test cases. There is a positive integer n (n<100) in the first line, which means the number of test cases, and then n 32-bit integers follow.
Output
For each test case, you should output its reverse number, one case per line.
Sample Input
3 12 -12 1200
Sample Output
21 -21 2100
这道题提交了2次才AC,第一次没有通过的原因是:在找结尾的0的范围时从前向后找的,忽略了中间有零的情况比如“10200”.
AC代码:
char a[10000];
#include <stdio.h>
#include <string>
int main() {
int N,len,i,k;
scanf("%d",&N);
while (N--) {
scanf("%s",a);
len=strlen(a);
for ( i=len-1; i>=0; i--) {
if (a[i]!='0')
break;
}
// printf("%d",i);
if (a[0]!='-') {
for (k=i; k>=0; k--) {
printf("%c",a[k]);
}
for (k=i+1; k<len; k++) {
printf("0");
}
}
else{
printf("-");
for (k=i; k>=1; k--) {
printf("%c",a[k]);
}
for (k=i+1; k<len; k++) {
printf("0");
}
}
printf("\n");
}
return 0;
}