Balanced Number-HDU - 3709(数位dp)

A balanced number is a non-negative integer that can be balanced if a pivot is placed at some digit. More specifically, imagine each digit as a box with weight indicated by the digit. When a pivot is placed at some digit of the number, the distance from a digit to the pivot is the offset between it and the pivot. Then the torques of left part and right part can be calculated. It is balanced if they are the same. A balanced number must be balanced with the pivot at some of its digits. For example, 4139 is a balanced number with pivot fixed at 3. The torqueses are 42 + 11 = 9 and 9*1 = 9, for left part and right part, respectively. It’s your job
to calculate the number of balanced numbers in a given range [x, y].
Input
The input contains multiple test cases. The first line is the total number of cases T (0 < T ≤ 30). For each case, there are two integers separated by a space in a line, x and y. (0 ≤ x ≤ y ≤ 10 18).
Output
For each case, print the number of balanced numbers in the range [x, y] in a line.
Sample Input
2
0 9
7604 24324
Sample Output
10
897
题意:找出指定区间的平衡数的个数(平衡数是指以一个位为中心轴,左力矩等于右力矩。)
PS:还是不会确定状态啊 只想到左右相等(结果M了),怎么就想不到和为0呢。
解释一下dfs函数四个参数以及状态的含义。
len:数到第几位
sum:数到当前位的力矩之和(数到最后为0的话就是平衡数)
piv:中心轴所在的位
limit:是否为上限
dp[i][j][k]: i:多少位 j:中心轴所在的位 k:数到当前位的力矩之和
(这里有个玄学,我初值赋0会T,赋-1就没事,搞不懂)

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <queue>
#define LL long long
using namespace std;
int digit[20];
LL dp[20][20][2000];
LL dfs(int len,int sum,int limit,int piv)
{
    if(len==0)	return sum==0;
    if(sum<0)  return 0; 
    //如果sum小于0,因为是从右向左数,后面的肯定是负数,直接返回0
	if(!limit && dp[len][piv][sum]!=-1) return dp[len][piv][sum];
    LL ans=0;
    int up=limit?digit[len]:9;
    for(int i=0;i<=up;i++)
    {
    	ans+=dfs(len-1,sum+i*(len-piv),limit&&i==up,piv);	
	}
	if(!limit) dp[len][piv][sum]=ans;
	return ans;	
} 

LL cal(LL a)
{
	int len=0;
	while(a)
	{
		digit[++len]=a%10;
		a/=10;
	}
	LL ans=0;
	for(int i=1;i<=len;i++)
	{
		//memset(dp,0,sizeof(dp));
		ans+=dfs(len,0,1,i);
	}
	return ans-(len-1);
}
int main()
{
   int t;
   scanf("%d",&t);
   memset(dp,-1,sizeof(dp));
   while(t--)
   {
   	 LL x,y;
   	 scanf("%lld%lld",&x,&y);
   	 
     printf("%lld\n",cal(y)-cal(x-1));
		 
   	  
   }

   return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值