POJ - 3368(RMQ ST表)

You are given a sequence of n integers a1 , a2 , ... , an in non-decreasing order. In addition to that, you are given several queries consisting of indices iand j (1 ≤ i ≤ j ≤ n). For each query, determine the most frequent value among the integers ai , ... , aj.

Input

The input consists of several test cases. Each test case starts with a line containing two integers n and q (1 ≤ n, q ≤ 100000). The next line contains nintegers a1 , ... , an (-100000 ≤ ai ≤ 100000, for each i ∈ {1, ..., n}) separated by spaces. You can assume that for each i ∈ {1, ..., n-1}: ai ≤ ai+1. The following q lines contain one query each, consisting of two integers i and j(1 ≤ i ≤ j ≤ n), which indicate the boundary indices for the 
query.

The last test case is followed by a line containing a single 0.

Output

For each query, print one line with one integer: The number of occurrences of the most frequent value within the given range.

Sample Input

10 3
-1 -1 1 1 1 1 3 10 10 10
2 3
1 10
5 10
0

Sample Output

1
4
3

最近在学ST表,开刷kuangbin训练  人一我百,人百我万.夕林山寸,寻梦指尖!

题目让你求区间内出现频率最高的数字。想了半天不知道怎么维护。。

最后看了题解才知道,还是太菜了。。。

新建一个数组a[i]表示连续数组出现的次数。

if(p[i]==p[i-1])
                a[i]=a[i-1]+1;
            else
                a[i]=1;

这样就可以分成两部分来求,第一部分是暴力求l到第一个1出现的位置,第二部分直接用RMQ求就行。

然后求两部分最大值即可。中间Wa了几次,由于没判断l>r时不能再求第一部分了。

感觉题目越做越有感觉 加油!!!

#include<cstdio>
#include<algorithm>
#include<iostream>
using namespace std;
#define maxn 100000+100
int dp[maxn][70];
int a[maxn];
int p[maxn];
void RMQ(int n)
{
	for(int i=1;i<=n;i++)
		dp[i][0]=a[i];
	for(int j=1;(1<<j)<=n;j++)
		for(int i=1;i+(1<<j)-1<=n;i++)
		{
			dp[i][j]=max(dp[i][j-1],dp[i+(1<<j-1)][j-1]);
		}
}
int query(int l,int r)
{
	int k=0;
	while(1<<k+1<=r-l+1)
		k++;
	return max(dp[l][k],dp[r-(1<<k)+1][k]);
}
int main()
{
	int n,q;
	while(scanf("%d",&n)&&n)
	{
		scanf("%d",&q);
		scanf("%d",&p[1]);
		a[1]=1;
		for(int i=2;i<=n;i++)
		{
			scanf("%d",&p[i]);
			if(p[i]==p[i-1])
				a[i]=a[i-1]+1;
			else
				a[i]=1;
		}
		a[n+1]=1;
		/*for(int i=1;i<=n;i++)
			cout<<p[i]<<"---"<<a[i]<<endl;*/
		RMQ(n);
		int l,r,m;
		while(q--)
		{
		//	cin>>l>>r;
			m=0;
			scanf("%d%d",&l,&r);
			while(a[l]!=1&&l<=r)
			{
				l++;
				m++;
				//cout<<m<<"+++"<<endl;
			}
			if(l<=r)
				m=max(m,query(l,r));
            cout<<m<<endl;
		//	printf("%d--%d++%d++%d\n",m,query(l,r),l,r);
			//cout<<query(l,r)<<endl;
		}
	}
	return 0;
}

人一我百,人百我万.夕林山寸,寻梦指尖!

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值