[kuangbin带你飞]专题5 并查集H - Navigation Nightmare POJ - 1984

Farmer John's pastoral neighborhood has N farms (2 <= N <= 40,000), usually numbered/labeled 1..N. A series of M (1 <= M < 40,000) vertical and horizontal roads each of varying lengths (1 <= length <= 1000) connect the farms. A map of these farms might look something like the illustration below in which farms are labeled F1..F7 for clarity and lengths between connected farms are shown as (n): 

           F1 --- (13) ---- F6 --- (9) ----- F3

            |                                 |

           (3)                                |

            |                                (7)

           F4 --- (20) -------- F2            |

            |                                 |

           (2)                               F5

            | 

           F7 


Being an ASCII diagram, it is not precisely to scale, of course. 

Each farm can connect directly to at most four other farms via roads that lead exactly north, south, east, and/or west. Moreover, farms are only located at the endpoints of roads, and some farm can be found at every endpoint of every road. No two roads cross, and precisely one path 
(sequence of roads) links every pair of farms. 

FJ lost his paper copy of the farm map and he wants to reconstruct it from backup information on his computer. This data contains lines like the following, one for every road: 

There is a road of length 10 running north from Farm #23 to Farm #17 
There is a road of length 7 running east from Farm #1 to Farm #17 
... 

As FJ is retrieving this data, he is occasionally interrupted by questions such as the following that he receives from his navigationally-challenged neighbor, farmer Bob: 

What is the Manhattan distance between farms #1 and #23? 

FJ answers Bob, when he can (sometimes he doesn't yet have enough data yet). In the example above, the answer would be 17, since Bob wants to know the "Manhattan" distance between the pair of farms. 
The Manhattan distance between two points (x1,y1) and (x2,y2) is just |x1-x2| + |y1-y2| (which is the distance a taxicab in a large city must travel over city streets in a perfect grid to connect two x,y points). 

When Bob asks about a particular pair of farms, FJ might not yet have enough information to deduce the distance between them; in this case, FJ apologizes profusely and replies with "-1". 

Input

* Line 1: Two space-separated integers: N and M



* Lines 2..M+1: Each line contains four space-separated entities, F1,

        F2, L, and D that describe a road. F1 and F2 are numbers of

        two farms connected by a road, L is its length, and D is a

        character that is either 'N', 'E', 'S', or 'W' giving the

        direction of the road from F1 to F2.



* Line M+2: A single integer, K (1 <= K <= 10,000), the number of FB's

        queries



* Lines M+3..M+K+2: Each line corresponds to a query from Farmer Bob

        and contains three space-separated integers: F1, F2, and I. F1

        and F2 are numbers of the two farms in the query and I is the

        index (1 <= I <= M) in the data after which Bob asks the

        query. Data index 1 is on line 2 of the input data, and so on.

Output

* Lines 1..K: One integer per line, the response to each of Bob's

        queries.  Each line should contain either a distance

        measurement or -1, if it is impossible to determine the

        appropriate distance.

Sample Input

7 6
1 6 13 E
6 3 9 E
3 5 7 S
4 1 3 N
2 4 20 W
4 7 2 S
3
1 6 1
1 4 3
2 6 6

Sample Output

13
-1
10

Hint

At time 1, FJ knows the distance between 1 and 6 is 13. 
At time 3, the distance between 1 and 4 is still unknown. 
At the end, location 6 is 3 units west and 7 north of 2, so the distance is 10. 

 

 

 

单纯的用并查集维护输入2各点之间的关系就行。

不过要先离线把所有查询存下来,边加入并查集  边进行查询。

根据两个点之间的相对关系,求出每个点的横纵坐标即可。

如果l==i进行查询。如果祖宗相同,那就可以计算距离,注意是求曼哈顿距离/。。

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<cstring>
#include<queue>
#include<string>
#include<map>
using namespace std;
const int M = 100000+199;
int f1[M],f2[M],l[M];
char s[M][2];
struct node 
{
	int l,r,t;
}q[M];
bool cmp (node a, node b)
{
	return a.t<b.t;
}
int fa[M],d[M];
int get(int x)
{
	if(fa[x]==x)return x;
	int root=get(fa[x]);
	return root;
}
double cal(int x1,int y1,int x2,int y2)
{
	double dis=abs((x2-x1)*1.0)+abs((y2-y1)*1.0);
	return dis;
}
int x[M],y[M];
bool vis[M];
int main()
{
	int n,m;
	cin>>n>>m;
	for(int i=1;i<=n;i++)fa[i]=i;
	for(int i = 1; i <= m; i++)
	{
		scanf("%d%d%d%s",&f1[i],&f2[i],&l[i],&s[i]);
	}
	int t;
	cin>>t;
	for(int i=1;i<=t;i++)
	{
		scanf("%d%d%d",&q[i].l,&q[i].r,&q[i].t);
	}
	sort(q+1,q+1+t,cmp);
	int cnt=1;//离线处理询问后,统一操作 
	x[f1[1]]=0;y[f2[1]]=0;
	vis[1]=true;
	for(int i=1;i<=m;i++)
	{
		int a=f1[i];
		int b=f2[i];
		int ga=get(a),gb=get(b);
		if(vis[b])//b->a; 
		{
			if(s[i][0]=='E')x[a]=x[b]-l[i],y[a]=y[a];
			else if(s[i][0]=='W')x[a]=x[b]+l[i],y[a]=y[b];
			else if(s[i][0]=='S')y[a]=y[b]+l[i],x[a]=x[b];
			else y[a]=y[b]-l[i],x[a]=x[b];
		}
		else//a->b 
		{
			if(s[i][0]=='E')x[b]=x[a]+l[i],y[b]=y[a];
			else if(s[i][0]=='W')x[b]=x[a]-l[i],y[b]=y[a];
			else if(s[i][0]=='S')y[b]=y[a]-l[i],x[b]=x[a];
			else y[b]=y[a]+l[i],x[b]=x[a];
		}
	//	printf("a=%d x[a]=%d y[a]=%d   b=%d  %d  %d\n",a,x[a],y[a],b,x[b],y[b]);
		vis[a]=true,vis[b]=true;
		fa[ga]=gb;
		if(q[cnt].t==i)
		{
			int l=q[cnt].l,r=q[cnt].r;
			int gl=get(l),gr=get(r);
			if(gl==gr)
			{
				double dis=cal(x[l],y[l],x[r],y[r]);
				cout<<dis<<endl;
			//	printf("%d  --- %d  %d  %d  %d  %d\n",l,r,x[l],y[l],x[r],y[r]);
			}
			else
			puts("-1");//得到当前数据后依然不能计算出x,y点的距离。 
			cnt++;
		}
	}
	return 0;
}
 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值