POJ 2891 多元同余线性方程

Strange Way to Express Integers
Time Limit: 1000MS Memory Limit: 131072K
   

Description

Elina is reading a book written by Rujia Liu, which introduces a strange way to express non-negative integers. The way is described as following:

Choose k different positive integers a1a2…, ak. For some non-negative m, divide it by every ai (1 ≤ i ≤ k) to find the remainder ri. If a1a2, …, ak are properly chosen, m can be determined, then the pairs (airi) can be used to express m.

“It is easy to calculate the pairs from m, ” said Elina. “But how can I find m from the pairs?”

Since Elina is new to programming, this problem is too difficult for her. Can you help her?

Input

The input contains multiple test cases. Each test cases consists of some lines.

  • Line 1: Contains the integer k.
  • Lines 2 ~ k + 1: Each contains a pair of integers airi (1 ≤ i ≤ k).

Output

Output the non-negative integer m on a separate line for each test case. If there are multiple possible values, output the smallest one. If there are no possible values, output -1.

Sample Input

2
8 7
11 9

Sample Output

31

Hint

All integers in the input and the output are non-negative and can be represented by 64-bit integral types.


题意:给你n个方程x≡ri(mod ai),求非负整数m,输出最小的一个,如果不存在,输出-1.

题解:典型的解同余方程组问题。

现在假设有两个方程x≡b1(mod m1)  x≡b2(mod m2)

有解的充分必要条件是gcd(m1,m2)|(b1-b2)

x=b1+m1y1 x=b2+m2y2

b1+m1y1=b2+m2y2

m2y2-m1y1=b1-b2

所以解出y2

答案就是(b2+m2y2)%m

所以我们只要对这些方程处理,每次将两个合并为一个即可


#include<iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
typedef long long ll;
void exgcd(ll a,ll b,ll &d,ll &x,ll &y){
	if(b==0){
		x=1;
		y=0;
		d=a;
		return ;
	}
	else{
		exgcd(b,a%b,d,x,y);
		ll temp=x;
		x=y;
		y=temp-(a/b)*y;
	}
}
void solve(ll n){
	ll a1,r1,a2,r2;
	scanf("%lld%lld",&a1,&r1);
	ll i;
	ll ifhave=1;
	for(i=1;i<n;i++){
		scanf("%lld%lld",&a2,&r2);
		ll a=a1;
		ll b=a2;
		ll c=r2-r1,d,x,y;
		exgcd(a,b,d,x,y);
		if(c%d)ifhave=0;
		ll t=b/d;
		x=(x*c/d);
		x%=t;
		x=(x+t)%t;
		r1=a1*x+r1;
		a1=a1*(a2/d);//a1要变成两个数的最小公倍数
	}
	if(!ifhave){
		printf("-1\n");//无解
	}
	else{
		printf("%lld\n",r1);
	}
}
int main(){
	ll n;
	while(scanf("%lld",&n)!=EOF){
		solve(n);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值