Layout----差分约束系统

Layout
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 11161 Accepted: 5362

Description

Like everyone else, cows like to stand close to their friends when queuing for feed. FJ has N (2 <= N <= 1,000) cows numbered 1..N standing along a straight line waiting for feed. The cows are standing in the same order as they are numbered, and since they can be rather pushy, it is possible that two or more cows can line up at exactly the same location (that is, if we think of each cow as being located at some coordinate on a number line, then it is possible for two or more cows to share the same coordinate). 

Some cows like each other and want to be within a certain distance of each other in line. Some really dislike each other and want to be separated by at least a certain distance. A list of ML (1 <= ML <= 10,000) constraints describes which cows like each other and the maximum distance by which they may be separated; a subsequent list of MD constraints (1 <= MD <= 10,000) tells which cows dislike each other and the minimum distance by which they must be separated. 

Your job is to compute, if possible, the maximum possible distance between cow 1 and cow N that satisfies the distance constraints.

Input

Line 1: Three space-separated integers: N, ML, and MD. 

Lines 2..ML+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at most D (1 <= D <= 1,000,000) apart. 

Lines ML+2..ML+MD+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at least D (1 <= D <= 1,000,000) apart.

Output

Line 1: A single integer. If no line-up is possible, output -1. If cows 1 and N can be arbitrarily far apart, output -2. Otherwise output the greatest possible distance between cows 1 and N.

Sample Input

4 2 1
1 3 10
2 4 20
2 3 3

Sample Output

27

Hint

Explanation of the sample: 

There are 4 cows. Cows #1 and #3 must be no more than 10 units apart, cows #2 and #4 must be no more than 20 units apart, and cows #2 and #3 dislike each other and must be no fewer than 3 units apart. 

The best layout, in terms of coordinates on a number line, is to put cow #1 at 0, cow #2 at 7, cow #3 at 10, and cow #4 at 27.

题目链接:http://poj.org/problem?id=3169


这个题是个差分约束系统的裸题,题目的意思就是说农夫养了N头牛,编号为1到N。按照编号顺序排成一排,在他们之间,有一些牛关系比较好,所以希望彼此之间不超过一定距离,也有一些牛关系比较不好,希望彼此之间至少要满足某个距离。给出了ML个关系好的,以及MD个关系不好的,求1号牛和N号牛之间的最大距离。如果不存在任何一种排列方法满足条件则输出-1.无限大的情况输出-2.


会差分约束系统直接看代码就可以了。

代码:

#include <cstdio>
#include <cstring>
#include <iostream>
#include <queue>
#define inf 0x3f3f3f3f
using namespace std;
struct node{
    int v,pre,w;
}edge[100000];
int p[10100],nEdge;
int dis[10100];
bool vis[10100];
int cis[10100];
inline void Init(){
    nEdge=0;
    memset(p,-1,sizeof(p));
    memset(cis,0,sizeof(cis));
    memset(vis,false,sizeof(vis));
}
inline void connect(int u,int v,int w){
    edge[nEdge].v=v;
    edge[nEdge].w=w;
    edge[nEdge].pre=p[u];
    p[u]=nEdge++;
}
inline bool SPFA(int n,int s){
    int t,v;
    queue<int >Q;
    for(int i=1;i<=n;i++){
        dis[i]=inf;
    }
    dis[s]=0;
    Q.push(s);
    cis[s]=1;
    vis[s]=1;
    while(!Q.empty()){
        t=Q.front();
        Q.pop();
        vis[t]=0;
        for(int i=p[t];~i;i=edge[i].pre){
            v=edge[i].v;
            if(dis[v]>dis[t]+edge[i].w){
                dis[v]=dis[t]+edge[i].w;
                if(!vis[v]){
                    vis[v]=1;
                    cis[v]+=1;
                    Q.push(v);
                    if(cis[v]>n)
                        return 0;
                }
            }
        }
    }
    return 1;
}
int main(){
    int n,m1,m2;
    int a,b,c;
    scanf("%d%d%d",&n,&m1,&m2);
    Init();
    for(int i=1;i<=m1;i++){
        scanf("%d%d%d",&a,&b,&c);
        connect(a,b,c);
    }
    for(int i=1;i<=m2;i++){
        scanf("%d%d%d",&a,&b,&c);
        connect(b,a,-c);
    }
    for(int i=1;i<=n-1;i++){
        connect(i+1,i,0);
    }
    if(!SPFA(n,1)){
        printf("-1\n");
    }
    else if(dis[n]!=inf){
        printf("%d\n",dis[n]);
    }
    else{
        printf("-2\n");
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值