EXTENDED LIGHTS OUT----状压或高斯消元

EXTENDED LIGHTS OUT
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 10256 Accepted: 6597

Description

In an extended version of the game Lights Out, is a puzzle with 5 rows of 6 buttons each (the actual puzzle has 5 rows of 5 buttons each). Each button has a light. When a button is pressed, that button and each of its (up to four) neighbors above, below, right and left, has the state of its light reversed. (If on, the light is turned off; if off, the light is turned on.) Buttons in the corners change the state of 3 buttons; buttons on an edge change the state of 4 buttons and other buttons change the state of 5. For example, if the buttons marked X on the left below were to be pressed,the display would change to the image on the right. 

The aim of the game is, starting from any initial set of lights on in the display, to press buttons to get the display to a state where all lights are off. When adjacent buttons are pressed, the action of one button can undo the effect of another. For instance, in the display below, pressing buttons marked X in the left display results in the right display.Note that the buttons in row 2 column 3 and row 2 column 5 both change the state of the button in row 2 column 4,so that, in the end, its state is unchanged. 

Note: 
1. It does not matter what order the buttons are pressed. 
2. If a button is pressed a second time, it exactly cancels the effect of the first press, so no button ever need be pressed more than once. 
3. As illustrated in the second diagram, all the lights in the first row may be turned off, by pressing the corresponding buttons in the second row. By repeating this process in each row, all the lights in the first 
four rows may be turned out. Similarly, by pressing buttons in columns 2, 3 ?, all lights in the first 5 columns may be turned off. 
Write a program to solve the puzzle.

Input

The first line of the input is a positive integer n which is the number of puzzles that follow. Each puzzle will be five lines, each of which has six 0 or 1 separated by one or more spaces. A 0 indicates that the light is off, while a 1 indicates that the light is on initially.

Output

For each puzzle, the output consists of a line with the string: "PUZZLE #m", where m is the index of the puzzle in the input file. Following that line, is a puzzle-like display (in the same format as the input) . In this case, 1's indicate buttons that must be pressed to solve the puzzle, while 0 indicate buttons, which are not pressed. There should be exactly one space between each 0 or 1 in the output puzzle-like display.

Sample Input

2
0 1 1 0 1 0
1 0 0 1 1 1
0 0 1 0 0 1
1 0 0 1 0 1
0 1 1 1 0 0
0 0 1 0 1 0
1 0 1 0 1 1
0 0 1 0 1 1
1 0 1 1 0 0
0 1 0 1 0 0

Sample Output

PUZZLE #1
1 0 1 0 0 1
1 1 0 1 0 1
0 0 1 0 1 1
1 0 0 1 0 0
0 1 0 0 0 0
PUZZLE #2
1 0 0 1 1 1
1 1 0 0 0 0
0 0 0 1 0 0
1 1 0 1 0 1
1 0 1 1 0 1
题目链接:http://poj.org/problem?id=1222


题目的意思就是说把全部的1变成0。

比赛碰到这个题了,高斯消元的题,我记得很清楚,但是我没有带板子,也好久没有敲高斯了,就想起了poj初级选林计划第一题,黑白棋那个,我就试着谢了发状压,然后就过了。。

我们考虑第一行的状态,那么下面的每一行都会根据上面一行1来确定,然后我们判断最后一行是不是符合条件即可。思路很简单,敲起来也比高斯消元好敲多了。


我在这里放上我的状压的代码,高斯消元的代码在我博客数学专题里有。

代码:

#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;
int map1[5][6],graph[5][6],xin[5][6];
bool judge(){
    for(int j=0;j<6;j++){
        if(graph[4][j])
            return 0;
    }
    return 1;
}
void change(int i,int j){
    graph[i][j]^=1;
    if(i>0)
        graph[i-1][j]^=1;
    if(j>0)
        graph[i][j-1]^=1;
    if(i<4)
        graph[i+1][j]^=1;
    if(j<5)
        graph[i][j+1]^=1;
}
int main(){
    int t;
    int cnt=0;
    scanf("%d",&t);
    while(t--){
        cnt++;
        for(int i=0;i<5;i++){
            for(int j=0;j<6;j++){
                scanf("%d",&map1[i][j]);
            }
        }
        printf("PUZZLE #%d\n",cnt);
        for(int k=0;k<64;k++){
            for(int i=0;i<5;i++){
                for(int j=0;j<6;j++){
                    graph[i][j]=map1[i][j];
                }
            }
            memset(xin,0,sizeof(xin));
            for(int j=0;j<6;j++)
                if(k&(1<<j)){
                    change(0,j);
                    xin[0][j]=1;
                }
            for(int i=1;i<5;i++)
                for(int j=0;j<6;j++)
                    if(graph[i-1][j]){
                        change(i,j);
                        xin[i][j]=1;
                    }
            if(judge()){
                for(int i=0;i<5;i++){
                    for(int j=0;j<=5;j++){
                        printf(j==0?"%d":" %d",xin[i][j]);
                    }
                    cout<<endl;
                }
                break;
            }
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值