POJ1222 Extended Lights Out(穷举)

POJ1222 Extended Lights Out(穷举)

Description

In an extended version of the game Lights Out, is a puzzle with 5 rows of 6 buttons each (the actual puzzle has 5 rows of 5 buttons each). Each button has a light. When a button is pressed, that button and each of its (up to four) neighbors above, below, right and left, has the state of its light reversed. (If on, the light is turned off; if off, the light is turned on.) Buttons in the corners change the state of 3 buttons; buttons on an edge change the state of 4 buttons and other buttons change the state of 5. For example, if the buttons marked X on the left below were to be pressed,the display would change to the image on the right.

这里写图片描述
The aim of the game is, starting from any initial set of lights on in the display, to press buttons to get the display to a state where all lights are off. When adjacent buttons are pressed, the action of one button can undo the effect of another. For instance, in the display below, pressing buttons marked X in the left display results in the right display.Note that the buttons in row 2 column 3 and row 2 column 5 both change the state of the button in row 2 column 4,so that, in the end, its state is unchanged.

这里写图片描述

Note:
  1. It does not matter what order the buttons are pressed.
  2. If a button is pressed a second time, it exactly cancels the effect of the first press, so no button ever need be pressed more than once.
  3. As illustrated in the second diagram, all the lights in the first row may be turned off, by pressing the corresponding buttons in the second row. By repeating this process in each row, all the lights in the first
    four rows may be turned out. Similarly, by pressing buttons in columns 2, 3 ?, all lights in the first 5 columns may be turned off.
    Write a program to solve the puzzle.

Input

The first line of the input is a positive integer n which is the number of puzzles that follow. Each puzzle will be five lines, each of which has six 0 or 1 separated by one or more spaces. A 0 indicates that the light is off, while a 1 indicates that the light is on initially.
Output

For each puzzle, the output consists of a line with the string: “PUZZLE #m”, where m is the index of the puzzle in the input file. Following that line, is a puzzle-like display (in the same format as the input) . In this case, 1’s indicate buttons that must be pressed to solve the puzzle, while 0 indicate buttons, which are not pressed. There should be exactly one space between each 0 or 1 in the output puzzle-like display.

Sample Input

2
0 1 1 0 1 0
1 0 0 1 1 1
0 0 1 0 0 1
1 0 0 1 0 1
0 1 1 1 0 0
0 0 1 0 1 0
1 0 1 0 1 1
0 0 1 0 1 1
1 0 1 1 0 0
0 1 0 1 0 0

Sample Output

PUZZLE #1
1 0 1 0 0 1
1 1 0 1 0 1
0 0 1 0 1 1
1 0 0 1 0 0
0 1 0 0 0 0
PUZZLE #2
1 0 0 1 1 1
1 1 0 0 0 0
0 0 0 1 0 0
1 1 0 1 0 1
1 0 1 1 0 1

算法

穷举,在Note部分暗示比较明显,穷举第一排(或第一列)的操作,一旦第一排(第一列)确定,后面的所有行(列)应该有的操作就全部确定了(前一排或列经过前一排操作仍为亮着的,下一排必须在对应位置进行反转,否则无法熄灭该灯)

Trick

增广数组,比如我的源码里开的是10*10的而不是5*6的(事实上7*8就足够),被操作范围下标是1-5*1-6,下标为0的行列多余了,则所有的反转操作可以归一为十字形(自己和上下左右),角落和边上的操作只是操作了多余的数组元素,不需要管它们。

#include<stdio.h>

void GetPuzzle(int Puzzle[10][10]);                                                                         
//Read in the puzzle
void GetFirstFour(int Puzzle[10][10], int Present[10][10], int FirstOpe[10], int Ope[10][10]);
//Get the first four rows' operation according to the first row operation
int Test(int Present[10][10]);
//Test the last row
void DisPlayOpe(int FirstOpe[10], int Ope[10][10]);
void Operate(int Present[10][10], int x, int y, int Go);
//flip the status

int main()
{
    int N;
    int Puzzle[10][10], Present[10][10], FirstOpe[10], Ope[10][10];

    scanf("%d", &N);
    for (int i = 1; i <= N; i++) {  
        GetPuzzle(Puzzle);
        for (FirstOpe[0] = 0; FirstOpe[0] <=1; FirstOpe[0]++)
        for (FirstOpe[1] = 0; FirstOpe[1] <=1; FirstOpe[1]++)
        for (FirstOpe[2] = 0; FirstOpe[2] <=1; FirstOpe[2]++)
        for (FirstOpe[3] = 0; FirstOpe[3] <=1; FirstOpe[3]++)
        for (FirstOpe[4] = 0; FirstOpe[4] <=1; FirstOpe[4]++)
        for (FirstOpe[5] = 0; FirstOpe[5] <=1; FirstOpe[5]++) {                                             
            //Exhausted search for the first row
            for (int j = 1; j <= 5; j++) {
                for (int k = 1; k <= 6; k++) {
                    Present[j][k] = Puzzle[j][k];
                }
            }
            GetFirstFour(Puzzle, Present, FirstOpe, Ope);
            if (Test(Present)) {
                printf("PUZZLE #%d\n", i);
                DisPlayOpe(FirstOpe, Ope);
            }
        }
    }

    return 0;
}

void GetPuzzle(int Puzzle[10][10])
{
    for (int i = 1; i < 6; i++) {
        for (int j = 1; j < 7; j++) {
            scanf("%d", &Puzzle[i][j]);
        }
    }
}

void GetFirstFour(int Puzzle[10][10], int Present[10][10], int FirstOpe[10], int Ope[10][10])
{
    for (int i = 1; i < 7; i++) {
        Operate(Present, 1, i, FirstOpe[i - 1]);
    }

    for (int i = 2; i < 6; i++) {
        for (int j = 1; j < 7; j++) {
            if (Present[i - 1][j]) {
                Ope[i][j] = 1;
            }
            else {
                Ope[i][j] = 0;
            }
            Operate(Present, i, j, Ope[i][j]);
        }
    }
}

void Operate(int Present[10][10], int x, int y, int Go)
{
    if (Go) {
        Present[x][y] = !Present[x][y];
        Present[x - 1][y] = !Present[x - 1][y];
        Present[x][y - 1] = !Present[x][y - 1];
        Present[x + 1][y] = !Present[x + 1][y];
        Present[x][y + 1] = !Present[x][y + 1];
    }
}

int Test(int Present[10][10])
{
    int BOOL = 1;

    for (int i = 1; i < 7; i++) {
        if (Present[5][i]) {
            return 0;
        }
    }

    return 1;
}

void DisPlayOpe(int FirstOpe[10], int Ope[10][10])
{
    printf("%d", FirstOpe[0]);
    for (int i = 1; i < 6; i++) {
        printf(" %d", FirstOpe[i]);
    }
    printf("\n");

    for (int i = 2; i < 6; i++) {
        printf("%d", Ope[i][1]);
        for (int j = 2; j < 7; j++) {
            printf(" %d", Ope[i][j]);
        }
        printf("\n");
    }
}
  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值