poj 1222 EXTENDED LIGHTS OUT

Description

In an extended version of the game Lights Out, is a puzzle with 5 rows of 6 buttons each (the actual puzzle has 5 rows of 5 buttons each). Each button has a light. When a button is pressed, that button and each of its (up to four) neighbors above, below, right and left, has the state of its light reversed. (If on, the light is turned off; if off, the light is turned on.) Buttons in the corners change the state of 3 buttons; buttons on an edge change the state of 4 buttons and other buttons change the state of 5. For example, if the buttons marked X on the left below were to be pressed,the display would change to the image on the right.


The aim of the game is, starting from any initial set of lights on in the display, to press buttons to get the display to a state where all lights are off. When adjacent buttons are pressed, the action of one button can undo the effect of another. For instance, in the display below, pressing buttons marked X in the left display results in the right display.Note that the buttons in row 2 column 3 and row 2 column 5 both change the state of the button in row 2 column 4,so that, in the end, its state is unchanged.


Note: 

1. It does not matter what order the buttons are pressed. 

2. If a button is pressed a second time, it exactly cancels the effect of the first press, so no button ever need be pressed more than once. 

3. As illustrated in the second diagram, all the lights in the first row may be turned off, by pressing the corresponding buttons in the second row. By repeating this process in each row, all the lights in the first 

four rows may be turned out. Similarly, by pressing buttons in columns 2, 3 ?, all lights in the first 5 columns may be turned off. 

Write a program to solve the puzzle.

Input

The first line of the input is a positive integer n which is the number of puzzles that follow. Each puzzle will be five lines, each of which has six 0 or 1 separated by one or more spaces. A 0 indicates that the light is off, while a 1 indicates that the light is on initially.

Output

For each puzzle, the output consists of a line with the string: "PUZZLE #m", where m is the index of the puzzle in the input file. Following that line, is a puzzle-like display (in the same format as the input) . In this case, 1's indicate buttons that must be pressed to solve the puzzle, while 0 indicate buttons, which are not pressed. There should be exactly one space between each 0 or 1 in the output puzzle-like display.

Sample Input

2
0 1 1 0 1 0
1 0 0 1 1 1
0 0 1 0 0 1
1 0 0 1 0 1
0 1 1 1 0 0
0 0 1 0 1 0
1 0 1 0 1 1
0 0 1 0 1 1
1 0 1 1 0 0
0 1 0 1 0 0

Sample Output

PUZZLE #1
1 0 1 0 0 1
1 1 0 1 0 1
0 0 1 0 1 1
1 0 0 1 0 0
0 1 0 0 0 0
PUZZLE #2
1 0 0 1 1 1
1 1 0 0 0 0
0 0 0 1 0 0
1 1 0 1 0 1
1 0 1 1 0 1

这题一个一个点搜索的话,时间按复杂度O(2^30) ,显然我们需要一个更简便的方法。

根据分析,我们发现一个点最多修改一次(你懂得),那么我们该如何控制搜索的顺序呢?

我们发现可以以行为单位,先枚举出第一行的操作方式,再依次将灯关掉(及对于G<i,j>点,当G<i-1,j>是开着的,我们就可以对这个点进行操作)。

最后判断是否全部关上(事实上我们只需要看最后一行是否全部关上)。


#include<cstdio>
#include<cstdlib>
#include<iostream>
#include<algorithm>
#include<cstring>
#include<string>
#include<queue>
#include<cmath>
using namespace std;
int T;
int a[10][10],status[10],tmp[10][10],puzzle[10][10];
void binary(int k){
     int cnt=6,js=0;
     while(cnt--){
        status[++js]=k%2;
        k/=2;
     }
}
void change(int x,int y){
    tmp[x][y]=!tmp[x][y];
    tmp[x-1][y]=!tmp[x-1][y];
    tmp[x][y-1]=!tmp[x][y-1];
    tmp[x+1][y]=!tmp[x+1][y];
    tmp[x][y+1]=!tmp[x][y+1];
    puzzle[x][y]=1;
}
void operate(){
    for (int i=1;i<=6;i++) if (status[i]) change(1,i);
    for (int i=2;i<=5;i++)
        for (int j=1;j<=6;j++)
            if (tmp[i-1][j]) change(i,j);
}
int judge(){
    int flag=1;
    for (int i=1;i<=6;i++) if (tmp[5][i]) flag=0;
    if (flag) return 1;
    return 0;
}
void reset(){
    memset(tmp,0,sizeof tmp);
    memset(puzzle,0,sizeof puzzle);
    for(int i=1;i<=5;i++)
        for(int j=1;j<=6;j++) tmp[i][j]=a[i][j];
}
int main(){
scanf("%d",&T);
for(int icase=1;icase<=T;icase++)
{

    for(int i=1;i<=5;i++)
        for(int j=1;j<=6;j++) scanf("%d",&a[i][j]);
    for(int i=0;i<64;i++)
    {
        reset();
        binary(i);//通过6位二进制枚举操作。
        operate();
        if (judge())
        {
            printf("PUZZLE #%d\n",icase);
            for(int i=1;i<=5;i++){
                for(int j=1;j<=6;j++) printf("%d ",puzzle[i][j]);printf("\n");
            }
            break;
        }
    }
}
return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值