hdu 1110 Equipment Box(数学)

Equipment Box

Problem Description
There is a large room in the Pyramid called Room-of-No-Return. Its floor is covered by rectangular tiles of equal size. The name of the room was chosen because of the very high number of traps and mechanisms in it. The ACM group has spent several years studying the secret plan of this room. It has made a clever plan to avoid all the traps. A specially trained mechanic was sent to deactivate the most feared trap called Shattered Bones. After deactivating the trap the mechanic had to escape from the room. It is very important to step on the center of the tiles only; he must not touch the edges. One wrong step and a large rock falls from the ceiling squashing the mechanic like a pancake. After deactivating the trap, he realized a horrible thing: the ACM plan did not take his equipment box into consideration. The box must be laid onto the ground because the mechanic must have both hands free to prevent contact with other traps. But when the box is laid on the ground, it could touch the line separating the tiles. And this is the main problem you are to solve.

Input
The input consists of T test cases. The number of them (T) is given on the first line of the input. Each test case consists of a single line. The line contains exactly four integer numbers separated by spaces: A, B, X and Y. A and Bindicate the dimensions of the tiles, X and Y are the dimensions of the equipment box (1 <= A, B, X, Y <= 50000).

Output
Your task is to determine whether it is possible to put the box on a single tile – that is, if the whole box fits on a single tile without touching its border. If so, you are to print one line with the sentence “Escape is possible.”. Otherwise print the sentence “Box cannot be dropped.”.

Sample Input
2
10 10 8 8
8 8 10 10

Sample Output
Escape is possible.
Box cannot be dropped.

参考博客:http://blog.csdn.net/were__wolf/article/details/16105527

这里写图片描述

ps:主要是斜着放没有想出来
斜着的话h要小于a

代码:

#include<stdio.h>
#include<math.h>
#include<algorithm>
using namespace std;

int judge(double a,double b,double x,double y)
{
    double k=sqrt(x*x+y*y);
    double angle=acos(y/k)-acos(b/k);
    double m=x*cos(angle)+y*sin(angle);
    if(m<a)
        return 1;
    return 0;
}

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        double a,b,x,y;
        scanf("%lf%lf%lf%lf",&a,&b,&x,&y);
        if(a<b)
            swap(a,b);
        if(x<y)
            swap(x,y);
        if(a>x&&b>y)//长和宽均满足条件
            printf("Escape is possible.\n");
        else if(b<=y||a*b<=x*y)//宽较小或者是面积较小
            printf("Box cannot be dropped.\n");
        else
        {
            if(judge(a,b,x,y))
                printf("Escape is possible.\n");
            else
                printf("Box cannot be dropped.\n");
        }
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值