hdu 1698 Just a Hook(线段树——区间更新)

115 篇文章 0 订阅
23 篇文章 0 订阅

Just a Hook

Problem Description
In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.

Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.

Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.

Output
For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.

Sample Input
1
10
2
1 5 2
5 9 3

Sample Output
Case 1: The total value of the hook is 24.

ps:两种方法,

第一种是裸的线段树区间更新,
代码:

#include<stdio.h>
#include<string.h>

#define maxn 100010
struct node
{
    int val,le,ri;
    int mid()
    {
        return (le+ri)>>1;
    }
} tree[maxn*4];
int add[maxn*4];
int n,m;

void Build(int rt,int left,int right)
{
    tree[rt].le=left;
    tree[rt].ri=right;
    if(left==right)
    {
        tree[rt].val=1;
        return ;
    }
    int mid=tree[rt].mid();
    Build(rt<<1,left,mid);
    Build(rt<<1|1,mid+1,right);
    tree[rt].val=tree[rt<<1].val+tree[rt<<1|1].val;
}

void Pushdown(int rt,int m)
{
    if(add[rt])
    {
        add[rt<<1]=add[rt];
        add[rt<<1|1]=add[rt];
        tree[rt<<1].val=add[rt]*(m-(m>>1));
        tree[rt<<1|1].val=add[rt]*(m>>1);
        add[rt]=0;
    }
}

void Updata(int rt,int left,int right,int num)
{
    if(tree[rt].le==left&&tree[rt].ri==right)
    {
        add[rt]=num;
        tree[rt].val=num*(tree[rt].ri-tree[rt].le+1);
        return ;
    }
    Pushdown(rt,tree[rt].ri-tree[rt].le+1);
    int mid=tree[rt].mid();
    if(right<=mid)
        Updata(rt<<1,left,right,num);
    else if(left>mid)
        Updata(rt<<1|1,left,right,num);
    else
    {
        Updata(rt<<1,left,mid,num);
        Updata(rt<<1|1,mid+1,right,num);
    }
    tree[rt].val=tree[rt<<1].val+tree[rt<<1|1].val;
}

int Query(int rt,int left,int right)
{
    if(tree[rt].le==left&&tree[rt].ri==right)
        return tree[rt].val;
    Pushdown(rt,tree[rt].ri-tree[rt].le+1);
    int mid=tree[rt].mid();
    if(right<=mid)
        return Query(rt<<1,left,right);
    else if(left>mid)
        return Query(rt<<1|1,left,right);
    else
        return Query(rt<<1,left,mid)+Query(rt<<1|1,mid+1,right);
}

int main()
{
    int t,x,y,z,k=0;
    scanf("%d",&t);
    while(++k<=t)
    {
        memset(add,0,sizeof(add));
        scanf("%d%d",&n,&m);
        Build(1,1,n);
        for(int i=1; i<=m; ++i)
        {
            scanf("%d%d%d",&x,&y,&z);
            Updata(1,x,y,z);
        }
        printf("Case %d: The total value of the hook is %d.\n",k,Query(1,1,n));
    }
    return 0;
}



第二种有一点小技巧
代码:

#include<stdio.h>

#define maxn 100010
int a[maxn][3];

int main()
{
    int t,k=0,n,m,tmp;
    scanf("%d",&t);
    while(++k<=t)
    {
        scanf("%d%d",&n,&m);
        for(int i=1; i<=m; ++i)
            scanf("%d%d%d",&a[i][0],&a[i][1],&a[i][2]);
        int ans=0;
        for(int i=1; i<=n; ++i)
        {
            tmp=1;
            for(int j=m; j>=1; --j)
            {
                if(i>=a[j][0]&&i<=a[j][1])
                {
                    tmp=a[j][2];
                    break;
                }
            }
            ans+=tmp;
        }
        printf("Case %d: The total value of the hook is %d.\n",k,ans);
    }
    return 0;
}
  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值