HDOJ-----1789贪心

Doing Homework again

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 11320    Accepted Submission(s): 6649


Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
 

Input
The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.
 

Output
For each test case, you should output the smallest total reduced score, one line per test case.
 

Sample Input
  
  
3 3 3 3 3 10 5 1 3 1 3 1 6 2 3 7 1 4 6 4 2 4 3 3 2 1 7 6 5 4
 
Sample Output
   
   
0 3

5



就是老师布置作业,规定时间前没做完就扣分,一门作业要做一天,问最少扣多少分
贪心的变形
先按规定时间升序排列,时间一样,再按扣分降序排列
就好比高数作业星期一截止,没做完扣一分,英语作业星期二截止,没做完扣20分。物理作业星期三截止没做完扣90分,
语文作业也是星期三截止,没做完扣60分,就要用星期一做语文作业,星期二做英语作业,星期三做物理作业,高数老师
罚就让他罚吧,反正扣一分
嗯,对高数满满的恶意--------

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
struct node{
    int a, b, c;
}s[10010];
bool cmp(node x, node y){
    if(x.a == y.a){
        return x.b > y.b;
    }
    return x.a < y.a;
}
int main(){
    int n, m;
    scanf("%d", &n);
    while(n--){
        memset(s, 0, sizeof(s));
        scanf("%d", &m);
        for(int i = 0; i < m; i++){
            scanf("%d", &s[i].a);
        }
        for(int i = 0; i < m; i++){
            scanf("%d", &s[i].b);
            s[i].c = 1;
        }
        sort(s, s + m, cmp);
        int k = 1, ok = 1, ans = 0, j, t;
        for(int i = 0; i < m; i++){
            if(s[i].a >= k){//先把第k天扣分最多的做完
                k++;
                continue;
            }
            ok = s[i].b;
            t = i;
            for(j = 0; j < i; j++){
                if(ok > s[j].b && s[j].c){//如上所述,取出前几天扣分最少的加入扣的总分里,并标记分已被扣除,下次要用扣分倒数第二低的来补
                    ok = s[j].b;
                    t = j;
                }
            }
            ans += ok;
            s[t].c = 0;
        }
        printf("%d\n", ans);
    }
    return 0;
}


Stkcd [股票代码] ShortName [股票简称] Accper [统计截止日期] Typrep [报表类型编码] Indcd [行业代码] Indnme [行业名称] Source [公告来源] F060101B [净利润现金净含量] F060101C [净利润现金净含量TTM] F060201B [营业收入现金含量] F060201C [营业收入现金含量TTM] F060301B [营业收入现金净含量] F060301C [营业收入现金净含量TTM] F060401B [营业利润现金净含量] F060401C [营业利润现金净含量TTM] F060901B [筹资活动债权人现金净流量] F060901C [筹资活动债权人现金净流量TTM] F061001B [筹资活动股东现金净流量] F061001C [筹资活动股东现金净流量TTM] F061201B [折旧摊销] F061201C [折旧摊销TTM] F061301B [公司现金流1] F061302B [公司现金流2] F061301C [公司现金流TTM1] F061302C [公司现金流TTM2] F061401B [股权现金流1] F061402B [股权现金流2] F061401C [股权现金流TTM1] F061402C [股权现金流TTM2] F061501B [公司自由现金流(原有)] F061601B [股权自由现金流(原有)] F061701B [全部现金回收率] F061801B [营运指数] F061901B [资本支出与折旧摊销比] F062001B [现金适合比率] F062101B [现金再投资比率] F062201B [现金满足投资比率] F062301B [股权自由现金流] F062401B [企业自由现金流] Indcd1 [行业代码1] Indnme1 [行业名称1] 季度数据,所有沪深北上市公司的 分别包含excel、dta数据文件格式及其说明,便于不同软件工具对数据的分析应用 数据来源:基于上市公司年报及公告数据整理,或相关证券交易所、各部委、省、市数据 数据范围:基于沪深北证上市公司 A股(主板、中小企业板、创业板、科创板等)数据整理计算
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值