HDOJ-1789 Doing Homework Again

Doing Homework again

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 16296    Accepted Submission(s): 9492


Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
 

Input
The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.
 

Output
For each test case, you should output the smallest total reduced score, one line per test case.
 

Sample Input
 
 
3 3 3 3 3 10 5 1 3 1 3 1 6 2 3 7 1 4 6 4 2 4 3 3 2 1 7 6 5 4
 

Sample Output
 
 
0 3 5

      一个关于做作业的贪心问题,开始时试了试按照截止日期排序和按照学分排序,发现第三个例子无法通过,仔细算了一下发现只有排序是无法通过的,中间还要有调整,就是把学分高的与截止日期早的但学分低的调换位置,因此换了一个思路,将学分从高到底排序,然后一天一天的分配作业,每一项作业都放在自己的截止日期那天做,如果截止日期有作业要做,便往前遍历,如果没有空余天数,就只好放弃这项作业。以下为代码实现:

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

struct hwork{
	int deadline;
	int score;
} hw[1010];
//建立一个数组,表示第i天是否有作业要做 
int vis[1010];
//安照学分从高到底、截止日期从早到晚排序,以保证高学分作业在前 
bool cmp( hwork aa , hwork bb ){
	return aa.score==bb.score?aa.deadline<bb.deadline:aa.score>bb.score;
}

int main(){
	int t,n;
	scanf( "%d",&t );
	while( t-- ){
		memset( vis,0,sizeof(vis) );
		scanf( "%d",&n );
		for( int i=0 ; i<n ; i++ ){
			scanf( "%d",&hw[i].deadline );
		}
		for( int i=0 ; i<n ; i++ ){
			scanf( "%d",&hw[i].score );
		}
		sort( hw,hw+n,cmp );
		int sum=0;
		//循环开始,确定某一天写哪一项作业 
		for( int i=0 ; i<n ; i++ ){
			int j = hw[i].deadline;
			while( j ){
				//如果某项作业的截止日期当天没有作业要做,做这项作业 
				if( !vis[j] ){
					vis[j] = 1;
					break;
				}
				//否则向前遍历看是否有空余的时间来做 
				j--;
			}
			//截止日期前的每一天都有作业要做,放弃这项作业,扣掉学分 
			if( j==0 ) 
				sum += hw[i].score;
		}
		printf( "%d\n",sum );
	}
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值