HDOJ-----1502贪心-----田忌赛马

Tian Ji -- The Horse Racing

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 26232    Accepted Submission(s): 7729


Problem Description
Here is a famous story in Chinese history.

"That was about 2300 years ago. General Tian Ji was a high official in the country Qi. He likes to play horse racing with the king and others."

"Both of Tian and the king have three horses in different classes, namely, regular, plus, and super. The rule is to have three rounds in a match; each of the horses must be used in one round. The winner of a single round takes two hundred silver dollars from the loser."

"Being the most powerful man in the country, the king has so nice horses that in each class his horse is better than Tian's. As a result, each time the king takes six hundred silver dollars from Tian."

"Tian Ji was not happy about that, until he met Sun Bin, one of the most famous generals in Chinese history. Using a little trick due to Sun, Tian Ji brought home two hundred silver dollars and such a grace in the next match."

"It was a rather simple trick. Using his regular class horse race against the super class from the king, they will certainly lose that round. But then his plus beat the king's regular, and his super beat the king's plus. What a simple trick. And how do you think of Tian Ji, the high ranked official in China?"



Were Tian Ji lives in nowadays, he will certainly laugh at himself. Even more, were he sitting in the ACM contest right now, he may discover that the horse racing problem can be simply viewed as finding the maximum matching in a bipartite graph. Draw Tian's horses on one side, and the king's horses on the other. Whenever one of Tian's horses can beat one from the king, we draw an edge between them, meaning we wish to establish this pair. Then, the problem of winning as many rounds as possible is just to find the maximum matching in this graph. If there are ties, the problem becomes more complicated, he needs to assign weights 0, 1, or -1 to all the possible edges, and find a maximum weighted perfect matching...

However, the horse racing problem is a very special case of bipartite matching. The graph is decided by the speed of the horses --- a vertex of higher speed always beat a vertex of lower speed. In this case, the weighted bipartite matching algorithm is a too advanced tool to deal with the problem.

In this problem, you are asked to write a program to solve this special case of matching problem.
 

Input
The input consists of up to 50 test cases. Each case starts with a positive integer n (n <= 1000) on the first line, which is the number of horses on each side. The next n integers on the second line are the speeds of Tian’s horses. Then the next n integers on the third line are the speeds of the king’s horses. The input ends with a line that has a single 0 after the last test case.
 

Output
For each input case, output a line containing a single number, which is the maximum money Tian Ji will get, in silver dollars.
 

Sample Input
  
  
3 92 83 71 95 87 74 2 20 20 20 20 2 20 19 22 18 0
 

Sample Output
   
   
200 0 0


就是田忌赛马,赢一场得200块钱,输一场输200块钱,平局没钱,问最多得多少钱
先比较田忌最慢的马与齐王最慢的马,能赢就赢,不能赢就去消耗齐王最快的马,
然后再来比较最快的马,能赢就赢,不能赢说明现在田忌和齐王最快的马和最慢
的马都相等,再来比较把田忌最慢的马和齐王最快的马,可能更小,但也可能相
等,如果相等就说明两方除了比较过的,现在所有马速度一样
循环下去就行了
-----摘自网络大神
具体证明是用数列,反正一大堆东西,最后就得出这么个结论


#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
int t[1010], k[1010];
int main(){
    int n, sum;
    while(~scanf("%d", &n), n){
        for(int i = 0; i < n; i++){
            scanf("%d", &t[i]);
        }
        for(int i = 0; i < n; i++){
            scanf("%d", &k[i]);
        }
        sort(t, t+n);
        sort(k, k+n);
        sum = 0;
        for(int ts = 0, tf = n-1, ks = 0, kf = n-1; kf >= ks || tf >= ts; ){
            if(t[ts] > k[ks]){//比较最慢的马,能赢就赢
                ts++;
                ks++;
                sum++;
            }
            else if(t[ts] < k[ks]){//不能赢,就用田忌最慢的消耗齐王最快的
                ts++;
                kf--;
                sum--;
            }
            
            else if(t[tf] > k[kf]){//比较双方最快的马,能赢就赢
                tf--;
                kf--;
                sum++;
            }
            else if(t[tf] < k[kf]){//不能赢就用田忌最慢的马消耗齐王最快的马
                ts++;
                kf--;
                sum--;
            }
            else if(t[ts] < k[kf]){//拿田忌最慢的和齐王最快的比,如果慢,就消耗
                ts++;
                kf--;
                sum--;
            }
            else{//如果一样,后边都是平局
                ts++;
                kf--;
            }
        }
        printf("%d\n", sum*200);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值