HDOJ-----1896栈

Stones

Time Limit: 5000/3000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 2044    Accepted Submission(s): 1345


Problem Description
Because of the wrong status of the bicycle, Sempr begin to walk east to west every morning and walk back every evening. Walking may cause a little tired, so Sempr always play some games this time.
There are many stones on the road, when he meet a stone, he will throw it ahead as far as possible if it is the odd stone he meet, or leave it where it was if it is the even stone. Now give you some informations about the stones on the road, you are to tell me the distance from the start point to the farthest stone after Sempr walk by. Please pay attention that if two or more stones stay at the same position, you will meet the larger one(the one with the smallest Di, as described in the Input) first.
 

Input
In the first line, there is an Integer T(1<=T<=10), which means the test cases in the input file. Then followed by T test cases.
For each test case, I will give you an Integer N(0<N<=100,000) in the first line, which means the number of stones on the road. Then followed by N lines and there are two integers Pi(0<=Pi<=100,000) and Di(0<=Di<=1,000) in the line, which means the position of the i-th stone and how far Sempr can throw it.
 

Output
Just output one line for one test case, as described in the Description.
 

Sample Input
  
  
2 2 1 5 2 4 2 1 5 6 6
 


Sample Output
  
  
11 12


水题,就是 这个人路上无聊,给定每个石头位置和可以扔的距离,遇到第奇数个石头就扔了,偶数个就跳过去不管,问最后一个石头距离初始位置多远


#include<cstdio>
#include<algorithm>
#include<queue>
#include<cstring>
using namespace std;
struct node{
    int x, y;
    friend bool operator < (node p, node q){//距离近的在前,相同距离,扔得远的在前
        if(p.x == q.x){
            return p.y > q.y;
        }
        return p.x > q.x;
    }
}s;
int main(){
    int a, b, c, t, k, u, dis;
    scanf("%d", &a);
    priority_queue <node> que;
    while(a--){
        scanf("%d", &u);
        dis = 0;
        k = 1;
        while(u--){
            scanf("%d%d", &s.x, &s.y);
            que.push(s);
        }
        while(!que.empty()){
            if(k & 1){
                s = que.top();
                s.x = s.x + s.y;
                que.pop();
                dis = s.x;//最后一个石头扔过之后的位置就是最远距离,因为下一次必定是偶数,而终点也必定是偶数
                que.push(s);
            }
            else{
                que.pop();
            }
            k++;
        }
        printf("%d\n", dis);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值