HDOJ 5479 Scaena Felix (栈)

Scaena Felix

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 660    Accepted Submission(s): 275


Problem Description
Given a parentheses sequence consist of '(' and ')', a modify can filp a parentheses, changing '(' to ')' or ')' to '('.

If we want every not empty <b>substring</b> of this parentheses sequence not to be "paren-matching", how many times at least to modify this parentheses sequence?

For example, "()","(())","()()" are "paren-matching" strings, but "((", ")(", "((()" are not.
 

Input
The first line of the input is a integer T , meaning that there are T test cases.

Every test cases contains a parentheses sequence S only consists of '(' and ')'.

1|S|1,000 .
 

Output
For every test case output the least number of modification.
 

Sample Input
  
  
3 () (((( (())
 

Sample Output
  
  
1 0 2 题意:给定一个由'('和')'组成的字符串,一次修改可以翻转字符串中的一个字符,将'('变成')'或者将')'变成 '('。如果要让这个字符串中任意一个非空子串都不是括号匹配串,至少要修改多少次? 比如"()","(())","()()" 是括号匹配串, 但"((", ")(", "((()" 不是。 思路:和括号匹配一样,存在一个括号匹配的时候,就计数cnt加一,然后最后共有多少对括号匹配,那么就要改多 少次。。 ac代码:
#include<stdio.h>
#include<math.h>
#include<string.h>
#include<stack>
#include<iostream>
#include<algorithm>
#define MAXN 10001
#define LL long long
#define INF 0xfffffff
using namespace std;
char s[MAXN];
int main()
{
    int t,n,m,i;
    scanf("%d",&t);
    while(t--)
    {
        stack<char>q;
        //stack<char>no;
        scanf("%s",s);
        int len=strlen(s);
        int cnt=0;
        for(i=0;i<len;i++)
        {
            if(q.empty())
            q.push(s[i]);
            else
            {
                char ch=q.top();
                if(ch=='('&&s[i]==')')
                q.pop(),cnt++;
                else
                q.push(s[i]);
            }
        }
        printf("%d\n",cnt);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值