HDOJ-----5631并查集

Rikka with Graph

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1042    Accepted Submission(s): 501


Problem Description
As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:

Yuta has a non-direct graph with n vertices and n+1 edges. Rikka can choose some of the edges (at least one) and delete them from the graph.

Yuta wants to know the number of the ways to choose the edges in order to make the remaining graph connected.

It is too difficult for Rikka. Can you help her?
 

Input
The first line contains a number T(T30) ——The number of the testcases.

For each testcase, the first line contains a number n(n100) .

Then n+1 lines follow. Each line contains two numbers u,v , which means there is an edge between u and v.
 

Output
For each testcase, print a single number.
 

Sample Input
  
  
1 3 1 2 2 3 3 1 1 3
 

Sample Output
  
  
9

n个点,n+1条边,问去除x条边依然n个点连通成一棵树,有多少种去法,没想到什么好方法,暴力过

因为n个点连通需要至少n-1条边,最多去掉两条边,去掉1条和2条分别暴力一下


#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define maxn 110 
int pre[maxn], dis[maxn];
int ok, ans;
struct node{
    int m, n;
}s[maxn];
int find(int a){
    return a == pre[a] ? a : pre[a] = find(pre[a]);
}
bool merge(int x, int y){
    int fx = find(x), fy = find(y);
    if(fx != fy){
        pre[fx] = fy;
        return true;
    }
    return false;
}
int main(){
    int x, y, t, o;
    scanf("%d", &o);
    while(o--){
        scanf("%d", &t);
        ans = 0;
        for(int i = 0; i <= t; i++){
            scanf("%d%d", &s[i].m, &s[i].n);
        }
        for(int i = 0; i <= t; i++){
            int cnt = t-1;
            for(int k = 1; k <= t; k++){
                pre[k] = k;
            }
            for(int j = 0; j <= t; j++){
                if(i != j && merge(s[j].m, s[j].n)){
                    cnt--;
                }
            }
            if(!cnt){
                ans++;
            }
        }
        for(int k = 0; k <= t; k++){
            for(int i = k+1; i <= t; i++){
                int cnt = t-1;
                for(int c = 1; c <= t; c++){
                    pre[c] = c;
                }
                for(int j = 0; j <= t; j++){
                    if(i != j && j != k && merge(s[j].m, s[j].n)){
                        cnt--;
                    }    
                }
                if(!cnt){
                    ans++;
                }
            }
        }
        printf("%d\n", ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值