hdoj5631Rikka with Graph

Problem Description
As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:

Yuta has a non-direct graph with n vertices and n+1 edges. Rikka can choose some of the edges (at least one) and delete them from the graph.

Yuta wants to know the number of the ways to choose the edges in order to make the remaining graph connected.

It is too difficult for Rikka. Can you help her?
 

Input
The first line contains a number T(T30) ——The number of the testcases.

For each testcase, the first line contains a number n(n100) .

Then n+1 lines follow. Each line contains two numbers u,v , which means there is an edge between u and v.
 

Output
For each testcase, print a single number.
 

Sample Input
  
  
1 3 1 2 2 3 3 1 1 3
 

Sample Output
  
  
9
有n个节点,给出n+1条边,现在要去删去至少一条边,使得删去后仍未连通图。(最多删去两条边)
代码如下 :
#include<stdio.h>
#include<string.h>
struct node{
	int a,b;
}arr[110];
int par[110],n;
int find(int x)
{
	if(x==par[x])
	return x;
	else
	return  par[x]=find(par[x]);
}
int judge(int x,int y)
{
	int i,ant=0;
	for(i=1;i<=n;i++)//初始化 
	par[i]=i;        
	for(i=0;i<=n;i++)
	{
		if(i==x||i==y)//
		continue;
	int fx=find(arr[i].a);
	int fy=find(arr[i].b);
	if(fx!=fy)
	{
		par[fx]=fy;
	}
	}
	for(i=1;i<=n;i++)
	{
		if(par[i]==i)
		ant++;
	}
   if(ant==1)
   return 1;
   else
   return 0;
}
int main()
{
	int t,i,j;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		for(i=0;i<=n;i++)
		scanf("%d%d",&arr[i].a,&arr[i].b);
		int ans=0;
		for(i=0;i<=n;i++)
		{
			for(j=i;j<=n;j++)
			{
				if(judge(i,j))
				ans++;
			}
		}
		printf("%d\n",ans);
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值