HDOJ-----3665最短路

Seaside

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1553    Accepted Submission(s): 1129


Problem Description
XiaoY is living in a big city, there are N towns in it and some towns near the sea. All these towns are numbered from 0 to N-1 and XiaoY lives in the town numbered ’0’. There are some directed roads connecting them. It is guaranteed that you can reach any town from the town numbered ’0’, but not all towns connect to each other by roads directly, and there is no ring in this city. One day, XiaoY want to go to the seaside, he asks you to help him find out the shortest way.
 

Input
There are several test cases. In each cases the first line contains an integer N (0<=N<=10), indicating the number of the towns. Then followed N blocks of data, in block-i there are two integers, Mi (0<=Mi<=N-1) and Pi, then Mi lines followed. Mi means there are Mi roads beginning with the i-th town. Pi indicates whether the i-th town is near to the sea, Pi=0 means No, Pi=1 means Yes. In next Mi lines, each line contains two integers S Mi and L Mi, which means that the distance between the i-th town and the S Mi town is L Mi.
 

Output
Each case takes one line, print the shortest length that XiaoY reach seaside.
 

Sample Input
  
  
5 1 0 1 1 2 0 2 3 3 1 1 1 4 100 0 1 0 1
 

Sample Output
  
  
2

一开始没看懂题,懵逼的很,百度翻译这东西不靠谱,还是好好学英语吧---

就是一个人想去海边,给出一个数代表n个城镇,0到n-1标号,出发点是0,然后下面一行两个数Mi,Pi,Mi是0号城镇有几条路,Pi代表城镇是否临海,1临海,0不临海,下面Mi行每行两个数代表与0号城镇相连的城镇标号和距离,之后是1号城镇有Mi条路,Pi代表是否临海,在接着Mi行表示与1号城镇相连的城镇标号与距离.......类推到n-1


#include<cstdio>
#include<queue>
#include<algorithm>
#include<cstring>
#define maxn 10100
#define inf 0x3f3f3f3f
using namespace std;
int head[maxn], dis[maxn], s[maxn], ss[maxn];
bool vis[maxn];
int m, n, ans, ok, num, x, y;
struct node{
	int from, to, val, next;
}edge[maxn*2];
void add(int u, int v, double w){
	node e = {u, v, w, head[u]};
	edge[num] = e;
	head[u] = num++;
}
void dij(int t){
	memset(dis, inf, sizeof(dis));
	memset(vis, false, sizeof(vis));
	queue <int > Q;
	dis[t] = 0;
	Q.push(t);
	while(!Q.empty()){
		int u = Q.front();
		Q.pop();
		vis[u] = false;
		for(int i = head[u]; i != -1; i = edge[i].next){
			int v = edge[i].to;
			if(dis[v] > dis[u] + edge[i].val){
				dis[v] = dis[u] + edge[i].val;
				if(!vis[v]){
					vis[v] = true;
					Q.push(v);
				}
			}
		}
	}
}
int main(){
	int c, a, b, x, y, d, N, M;
	while(~scanf("%d", &N)){
		num = m = 0;
		memset(head, -1, sizeof(head));
		for(int i = 0; i < N; i++){
			scanf("%d%d", &a, &b);
			if(b){
				s[m++] = i;
			}
			for(int j = 0; j < a; j++){
				scanf("%d%d", &c, &d);
				add(i, c, d);
				add(c, i, d);
			}
		}
		dij(0);
		ans = inf;
		for(int i = 0; i < m; i++){
			if(ans > dis[s[i]]){
				ans = dis[s[i]];
			}
		}
		printf("%d\n", ans);
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值