POJ-----1745Divisibility

Divisibility
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 11525 Accepted: 4132

Description

Consider an arbitrary sequence of integers. One can place + or - operators between integers in the sequence, thus deriving different arithmetical expressions that evaluate to different values. Let us, for example, take the sequence: 17, 5, -21, 15. There are eight possible expressions: 17 + 5 + -21 + 15 = 16 
17 + 5 + -21 - 15 = -14 
17 + 5 - -21 + 15 = 58 
17 + 5 - -21 - 15 = 28 
17 - 5 + -21 + 15 = 6 
17 - 5 + -21 - 15 = -24 
17 - 5 - -21 + 15 = 48 
17 - 5 - -21 - 15 = 18 
We call the sequence of integers divisible by K if + or - operators can be placed between integers in the sequence in such way that resulting value is divisible by K. In the above example, the sequence is divisible by 7 (17+5+-21-15=-14) but is not divisible by 5. 

You are to write a program that will determine divisibility of sequence of integers. 

Input

The first line of the input file contains two integers, N and K (1 <= N <= 10000, 2 <= K <= 100) separated by a space. 
The second line contains a sequence of N integers separated by spaces. Each integer is not greater than 10000 by it's absolute value. 

Output

Write to the output file the word "Divisible" if given sequence of integers is divisible by K or "Not divisible" if it's not.

Sample Input

4 7
17 5 -21 15

Sample Output

Divisible

给出n,k,下面n个数,这n个数顺序不变,中间可以添加+和-这两种标点符号,问这个式子的值能不能通过某一组标点符号被k整除

按顺序遍历n个数

遍历出第一个数的余数

然后遍历第二个数,用第一个余数对第二个数分别+和-操作,再求余数

然后遍历第三个数,用第二个余数对第三个数进行+和-操作,再求余数

……

一直遍历到第n个数,看是否能被k整除

dp和同余的结合


#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define maxn 10010
int s[maxn];
bool dp[maxn][110];
int main(){
	int n, k;
	scanf("%d%d", &n, &k);
	memset(s, 0, sizeof(s));
	memset(dp, false, sizeof(dp));
	for(int i = 1; i <= n; i++){
		scanf("%d", &s[i]);
	}
	dp[1][(s[1]%k+k)%k] = true;
	for(int i = 2; i <= n; i++){
		for(int j = 0; j < k; j++){
			if(dp[i-1][j]){
				dp[i][((j+s[i])%k+k)%k] = true;
				dp[i][((j-s[i])%k+k)%k] = true;
			}
		}
	}
	printf(dp[n][0] ? "Divisible\n" : "Not divisible\n");
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值