HDOJ-----1058---Humble Numbers(DP)

11 篇文章 0 订阅
9 篇文章 0 订阅

A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers.

Write a program to find and print the nth element in this sequence
 

Input
The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.
 

Output
For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output.
 

Sample Input
  
  
1 2 3 4 11 12 13 21 22 23 100 1000 5842 0
 

Sample Output
  
  
The 1st humble number is 1. The 2nd humble number is 2. The 3rd humble number is 3. The 4th humble number is 4. The 11th humble number is 12. The 12th humble number is 14. The 13th humble number is 15. The 21st humble number is 28. The 22nd humble number is 30. The 23rd humble number is 32. The 100th humble number is 450. The 1000th humble number is 385875. The 5842nd humble number is 2000000000.

跟丑数的思想一样的,若n符合题意,那么n*2,n*3,n*5,n*7也符合题意,n为1是符合题意,从1开始遍历就好了

因为是递增排序,所以用优先队列来维护,再用map判断一下是否有重复的就可以了

从题目可知最大值为2e9,所以int足够保存,再把大于这个范围的排除,稍微减少内存消耗

#include<cstdio>
#include<iostream>
#include<cmath>
#include<cstring>
#include<string>
#include<algorithm>
#include<map>
#include<queue>
#include<vector>
#include<functional>
#define PI acos(-1.0)
#define INF 0x3f3f3f3f
#define CL(a, b) memset(a, b, sizeof(a))
using namespace std;
typedef long long LL;
const int maxn = 5e5+10;
const int MOD = 1e9+7; 
int cnt[maxn];
char s[20][5] = {"th", "st", "nd", "rd", "th", "th", "th", "th", "th", "th"};
int v[5] = {2, 3, 5, 7};
int main(){  
    int n, t, ans, kcase = 1;
    priority_queue <int, vector<int>, greater<int> >Q;
	Q.push(1);
	ans = 1;
	cnt[ans] = 1;
	map <int, bool> M;
	while(1){
		LL c = Q.top();
		Q.pop();
		cnt[ans++] = c;
		if(ans == 5843) break;
		for(int i = 0; i < 4; i++){
			if(!M[c*v[i]] && c*v[i] < MOD*2){
				Q.push(c*v[i]);
				M[c*v[i]] = true;
			}
		}
	} 
    while(scanf("%d", &n) && n){
		printf("The %d", n);
		if(n%100 < 14 && n%100 > 10) printf("th");
		else printf("%s", s[n%10]);
		printf(" humble number is %d.\n", cnt[n]);
	}
    return 0;  
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值